Newer MDS Fails with 15gb PKG

#1

I’ve been using MDS for a few weeks, going through and finalizing all the packages I have to install, and one of them is giving me problems. Of course, it’s the largest and most difficult one to create – a Winclone package of a Boot Camp partition of Windows 10. The PKG itself works fine, as far as I can tell. It installs correctly on a separate system, boots, no problem. The problem, maybe, is that the PKG is 14.88gb. When MDS goes through the package list, it copies everything onto the USB drive, but when it gets to the Winclone package, it fails says “An error occurred embedding the package /var/folders/vs/3ksnq0ns5yb9_v2mbrzkyy300000gn/T/BE93C038-A0DD-4FD7-85FA-29EDC0E33606.pkg, Please check the package and free space and try again.” (The file name and path appear random each time.)

I formatted the USB stick a couple times, and it’s brand new anyway so I don’t think that’s the problem. It’s a 32gb USB also, and the contents of MDS are less than 22g (6gb for Mojave and 15gb for Windows). I removed all the other packages from the MDS for testing, but it hasn’t helped. I also tested on MDS 1.4, and the 1.6 beta, build 11356. Both give the same error.

This package is an updated version of a previous one that worked, but I don’t remember the version of MDS that it worked on. It was a couple weeks ago, so maybe 1.3 or 1.2, but I’m not sure, and I don’t have the old version anymore to test. The file names are Win10LTSCv1.pkg and WIN10LTSCv2.pkg, and the sizes are 14.8gb and 14.88gb, so not a big difference between them.

0 Likes

#2

I just tried copying to the USB stick manually, and the error I get is “Error: The specified file is not a valid product archive”.

Any ideas?

0 Likes

#3

I love it when I can reply to my own message with the solution…

Since originally posting this, I saw the new video on Youtube with the “priority” for packages. Once I clicked the little arrow icons and set the Windows package to install “When Running Workflow”, the error disappeared! It’s a weird error to get when there’s plenty of free space and there’s nothing wrong with the package, but at least it works now. Thanks Tim!

0 Likes

#4

Thanks for replying back! To answer your question, when macOS creates a package, it makes multiple copies of the original. Originally, MDS was putting the winclone package inside another package, and this caused the massive use of disk space!

MDS now just uses the package from Winclone and doesn’t package it.

tim

0 Likes

#5

Actually, I spoke too soon. MDS created the USB fine, but the package won’t install. It gives me an error saying “Couldn’t install /Volumes/MDS/Deploy/Workflows/Dual-Boot-Classroom/PreOS-Packages/Win10LTSCv2.1.pkg”. The terminal window has a handful of “Running package scripts” messages, interspersed with percentages. The last one says 97.75 percent complete, then “The install failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.)”, then “No handlers could be found for logger ‘Imagr’”.

The installer.log has an error, “2019-04-09 15:20:11+00 MacBook-Pro installer[908]: ./postflight: /Volumes/MDS/Deploy/Workflows/Dual-Boot-Classroom/PreOS-Packages/Win10LTSCv2.1.pkg/Contents/Resources/postflight: line 343: bc: command not found”. Sure enough, the command “bc” doesn’t exist in Recovery Mode apparently. In creating the package, I used the 50% option, along with the selections you used in the recent Youtube video. I haven’t tested whether setting a specific size works yet, although I can if needed.

0 Likes

#6

I tried setting a specific partition size in Winclone, and setting the package to install during the workflow. I let it go overnight, and came in this morning to see a window saying that it failed, and to either reload workflows, or select a startup disk.

The install.log seems to indicate that it installed correctly, and took 10547 seconds to do so (roughly 3 hours)… but right afterward, it seems like it tried to install it again and failed. I uploaded the install.log to pastebin - https://pastebin.com/iU2BLGEF.

At this point, I’m guessing it’s a compatibility thing between Winclone and MDS. It looks like Winclone is creating a package that can’t be installed during Recovery Mode, but MDS won’t allow me to set the package to install post-install, so I’m not sure what to do now.

0 Likes

#7

The other thing of note is that when I try the MDS, the process removes ALL of the partitions on the drive, including the Recovery partition. To fix it, I have to boot to a Mojave USB stick, and go through the Mojave install, then try again… so it’s very time consuming.

0 Likes

#8

we just posted a beta to winclone that should resolve the issue. As you found, the issue was in the postflight script. Download the beta here:

You just need to create the package again, not the Winclone image. Let me know how it works out.

tim

1 Like

#9

Awesome, thanks! I’ll report back as soon as I copy the new package and test it.

Does it also fix the Recovery Partition being wiped?

0 Likes

#10

I made a new package, and started the process, and while I don’t get an error, it doesn’t look like it’s doing anything. I’ve let it run for almost 4 hours so far, and looking at the install.log file, it’s just hundreds of lines of this:

2019-04-10 21:13:06+00 MacBook-Pro installer[804]: ./postflight: 2019-04-10 21:15:13.302 winclone[828:51811] ~~~~~~~ Extracting file data: 0 GiB of 32 GiB (0%) done ~~~~~~~

I’ll let it go overnight, but after this long, it looks like it’s stuck in a loop of some sort.

0 Likes

#11

Extracting file data is the 3rd step (verifying, creating files, then extracting data). I think it is going to work!

tim

0 Likes

#12

It worked! It took about 6 hours, from start to finish, but it did work! I’m duplicating the MDS onto a bunch of USB sticks now, so I can get building. Thanks!

0 Likes

#13

Thanks for letting me know! Awesome!

tim

0 Likes