"no bootable device" after Win10 image restored/package unrolled on iMac

Hi there,

we successfully installed Win10 on a bootcamp partition on one iMac with Sierra 10.12.5. (500gb/500gb partitions)
Then created an image (successfully with Winclone 6.1.7 Pro (17510)
Also tried with created package (successfully, 50/50 partition)
Copied on to another iMac (same hardware: late 2012, 3.2ghz intel i5, 16gb, 1600mhz ddr3, GeForce675MX)
one SATA disk, two partitions both GPT (GUID), S.M.A.R.T status: checked, S.I.P. disabled successfully by “csrutil…”)

… and enrolled / restored to bootcamp
(tried both with package and with pure image, we have more than one target Mac)

both was “successfully” but booting BootcampPartition ended up in

“no bootable device - insert boot disk and press any key” (after rEFIt boot menu) - boot stick and any key didn’t help

or WIndowsLogo trying to boot, then blackscreen (iMac makes sounds but never boots properly)

(Macintosh partition works perfectly, disk utility shows half mac half bootcamp)

in boot menu / disk utility the Windows partition is only called “bootcamp” / “efi boot” (never “Windows”)

chkdsk with win10 system usb worked, found problems, and “solved” them…but no effect

also tried:

  • formatted bootcamp (also with FAT32) …

  • again created+unrolled package, again restored image

  • deactivated rEFIt - same problem (in boot menu after holding ALT/option)

  • NVRAM reset and Windows restart …Windows made system check - no effect

  • “make EFI bootable” with Winclone …seemed to work - no effect

  • “diskutil mount disk0s4” in terminal …bootcamp successfully mounted - no effect, but: cannot access OS again :frowning:

Any ideas?

Best greetings

It may be setting up the package restore as not EFI and that version of Windows may require it. After you restore the package, try setting the Windows install to be EFI bootable:

If that is the case, I can give you instructions on how to force EFI mode in the package.



thanks for the response!
But we’re still having problems fixing it.

I suppose boot-mode is already set to EFI-boot by default, setting it to EFI-boot (again?) doesn’t change anything at booting windows. The iMacs aren’t on the list of Macs that don’t support EFI-boot, but in the boot-menu in only says EFI-Boot instead of Windows.
Switching to Legacy-mode changes that, it now says Windows in the bootmenu, but booting into that partition results in a blue screen saying that the computer needs to be repaired, with the errorcode 0x0000225 and that the file \WINDOWS\system32\winload.exe is missing or has errors.
But anyways, it should be able to boot in efi-mode, right? When I mount the EFI-Partitions on the working master-computer and another not working one, on the first there are only two folders, APPLE and Microsoft, whereas on the second there is also a third one, the boot folder. Why is there a difference?

Any ideas on how we can proceed now?
What do you think of sysprep, would you recommend that? Would we have to change back lots of settings on the clients?

A couple of things to try:

  1. Try restoring the image directly in Winclone to make sure it is a image related issue versus package.
  2. Disable SIP and try both restoring from Winclone and the package.
  3. Look in the package log and see if there was any errors (and post back the output). Here is how to get the package log:


I would be very interested in the instructions on how to force a package to deploy in EFI mode (and legacy mode if possible). Thanks in advance!

I created a kbase on how to do it:



1 Like