No Bootable device error, "Make EFI bootable" or "Legacy..." hanging for hours

Hello everybody. I managed to break the Bootcamp boot partition somehow, attempting to solve a “no bootable device found” error at boot by fumbling with the bootrec and other commands in Win 10 Rec disc (USB) version. So I disabled SIP and tried to apply the “make legacy bootable” option first (I have a mid 2011 MacMini), but the option just stuck at 0% progress, and then tried the “make EFI bootable” option which behaved the same way. Any suggestions, please ? Which option of the two would be better for me, anyway ? I’m trying not to reinstall Windows, because I have so many data on the Bootcamp partition it would basically take me months to reinstall all the Win apps stored in it. Thank you very much.

Can you try again, and then send me the logs from the help menu? Put a link to this forum post in the description.


Last time it created a partition called “EFI” that wasn’t there before and today I couldn’t cancel the procedure, so I had to exit and reopen the app and I couldn’t make a log after I had tried to run one of the two options. Anyway here it is:

I had exactly the same problem with my 2011 Mac mini, struggling for days. The answer for me was to select “Legacy Boot”.

I think the app is messing up my partition scheme, since it can’t finish the job. I’d better let it go…

Winclone doesn’t change the partition scheme, but does write to the master boot record and data to the partition.


Ok, but after 2 or 3 attempts i saw 3 raw mini partitions appearing next to the usual ones. I don’t want to mess up an already serious situation in which I can’t boot Windows anymore and the app is not completing the requested tasks. About that, do you have any idea why is it behaving this way?

Please run “diskutil list” in Terminal and it should show these extra partitions, Paste the results.


/dev/disk0 (internal, physical):
0: GUID_partition_scheme *500.1 GB disk0
1: EFI EFI 209.7 MB disk0s5
2: Apple_HFS Macintosh HD 378.0 GB disk0s6
3: Apple_Boot Recovery HD 650.0 MB disk0s7
4: Microsoft Basic Data BOOTCAMP 121.2 GB disk0s8

That looks perfect. Did you see the partitions in Disk Utility? I have noticed that sometimes Disk Utility will show a extra partition, but if you quit and launch it, it will show the correct ones.


I am trying to work it out in the Apple Support Community. Thanks anyway.

Can you share the link to the forum post?