Not able to boot into windows 10 bootcamp from External Drive


#1

I’m hoping this is an easy fix as I’ve been in the forums and youtube but have not found an answer.

When I restore a winclone image to new formatted external SSD drive the process completes but when I go to System Preferences, StartUp Disk, the new boot camp on the external drive is not showing up. When I restart and hold the option key its not listed there.
Any ideas? ; )

(background, winclone

7, 2018 mac mini, mojave, bootcamp OS is windows 10). created a new bootcamp on the 2018 mac mini and that works fine (boots into windows 10 perfectly. did a winclone backup to image, then deleted internal bootcamp partition on the main internal hard drive, then plugged in my external SSD, formatted it fresh with disk utility (tried NTFS and ExFat), then restored the image the external drive. Seemed to restore fine but after Startup doesn’t see the bootcamp OS, or does selecting the OS at boot (holding the option key) I have 2 different external SSD’s and the same thing on both happens. Thanks!


#2

Also, i’ve tried using the ‘make efi bootable’ tool but that doesn’t help either 35%20AM


#3


#4

UPDATE: because this is a newer mac mini with the T2 security chip i had to change the settings in order to see the drive. https://support.apple.com/en-us/HT208330

I changed all the settings (no security, allow external booting), it now sees the drive but get windows errors trying to boot into windows. (when i take that external drive and plug it in to my 2015 macbook pro, bootcamp from that same external ssd works fine)

Help! thanks.


#5

This is most likely due to drivers. You can inject the updated drivers to the installed version of Windows:

tim


#6

Thank you, trying this now.


#7

Hello, i’ve tried this 3 different times and i get the same error trying to boot into either the external SSD bootcamp partition or using the windows 10 boot usb as descibed in the help file (so i’m not able to inject the drivers).

On boot occasions (booting via usb thumb or bootcamp external) it shows up as EFI boot, loads into the widows logo then just hangs.

again, this works on my 2015 macbook pro but no my mac mini 2018


#8

Still no luck. I’ve tried disabling SIP but to no luck. Its just my 2018 mac mini that can’t boot into windows (i’ve tried 2 other older macs and it works fine). I can boot from another mac OS (like carbon copy cloner) just fine. Its just windows bootcamp and windows setup don’t work. When i’m in mojave and go to system pref, start up, it sees the bootcamp disk and when i select it, it restarts then i get a bluescreen error.


#9

Hi, worked on this for about 4 hours this weekend and still no luck, i’m so frustrated :frowning:

Any insights? I could really use some help, thank you.


#10

Can you give more information on what the bluescreen error is? Is it inaccessible device?

tim


#11

Sure, i took a picture of it.


#12

Hopefully you might have some insight! It seems the newer T2 based machines adds a layer of complexity the older machines don’t tend to have. I’d really like to run bootcamp from an external SSD for size and ease fulness. (vs installing bootcamp on my main Macintosh HD internal drive and just loaded programs and files on the external ssd drive. that is an option but doesn’t seem as clean especially when i want to back up using winclone 7 (not sure if it backs up to an image when windows 10 is on 2 drives!)

Thanks and look forward to hearing from you


#13

Hi any update?Thank you


#14

HI just checking into see if there has been any update to this case, thanks


#15

Hi,
I have exactly the same problem and also try to solve it for almost two days. I copied a working bootcamp partition to my external drive. I can select the drive to boot, but it reboots while I boot windows, and then I come to this blue screen.

In safe mode Windows starts but the screen flickers very strongly and at start the message “sihost.exe unknown hard error” appears.
I have tested the procedure several times and also with different Windows versions. Could it be that it is a Thunderbolt drive?

Setup:
MBP Late 2016
Samsung X5 500GB
Windows 10 Sep 2018

Daennes