On the Mac select startup disk Windows drive not there

So suddenly my Windows drive does not appear in the Macs startup preferences. I can only start Windows by holding the option key after I restart. Is there a software fix for this? On a 2017 iMac 5k running the latest version of Winclone 7 and 10.13.6 Mac OS.

Try the latest beta:

I’m on 7.1.3. and the drive is still not bootable. I also get a second partition EFI and bootcamp? Never got this before. Why would it create a separate partition which makes it unbeatable?


does the EFI partition files on it or does it have Apple, Boot, and Microsoft? If the latter, it is just the EFI partition that is on all GPT disks.


So what does that mean EFI partition that is on all GPT disks? How do I get my restore to my external to be bootable? Winclone doesn’t seem to be able to do that anymore?

winclone definitely still supports that and we do regular QA testing to make sure it does. Not sure what the specific issue you are running into. It is strange that the EFI partition is showing up on the desktop, which is why I was asking if it was a standard EFI volume.


I have followed the Winclone procedure and Winclone when it does the restore formats the drive. So I don’t know what I’m doing that is causing this issue. I had no problems when I was using Winclone 6.
I turned off the security protection on the Mac OS. I ran CHKDSK, I ran sysprep and shutdown. I run the restore and I don’t get a bootable Windows disk. I have a licensed copy of Windows 10PRO. Is there anything I’m missing?

Okay tried one more thing which was to run the legacy boot utility. Now the external bootcamp drive shows up in startup but the disk cannot be blessed as a bootable disk. I have a working internal bootcamp but wanted the external bootcamp to boot which I cloned following the instructions given here.
Now what?

If you hold option key down when starting up, does it now show as a bootable volume and does it boot into it?


Nope, doesn’t show up at all unfortunately.

Is hard drive size an issue? The one I was attempting to install on was 5TB. But the format was only for like 2TB when the clone finished. Would this matter?

Can you explain a bit more? How is this different from using Winclone 6? or is it a different scenario? It definitely should be EFI bootable since it is a 2017 iMac.


It seemed as if Version 6 worked flawlessly while I have had a lot of trouble with 7. I did finally get it work. But now the assigned drive letters go away after reboot. So I have to assign an external drive letter D every single time. Is there a fix for this? Also with an external drive OSX will not see it in the restart menu. I always have to option boot to see the external bootable Windows drive.

I have not seen this before but will investigate. Can you give me your exact setup so I can replicate here?


4.2GHZ i7 5K iMac 2017 16GB of ram. 8 GB Radeon Pro 580 video chip.? High Sierra 10.13.6 Mac OS. Winclone 7.1.4. BootCamp cloned to a 2TB ST2000LM007 USB external drive plugged directly into the iMacs USB port.

I see there was another update for WinClone to 7.2.

We have a 2017 5K iMac here and an external 1 TB USB SSD. I’ll validate that it works per your config.


Are you guys also testing Mojave with Winclone 7? Does Mojave work as far as you know?

We did full testing on Mojave, and it is working great! Here is the our status page: