Possible bug in 7.3 Legacy Restore (6.2.2 Restores OK)

I beat myself nearly to death on Saturday trying to do a Windows 7 Pro x64 Legacy-boot restore to a Late 2013 iMac from a Late 2013 iMac. On the Saturday before, I created an image from the donor iMac (again, a Late 2013 with a 1TB HD) using WinClone 4.4. (At the time, thanks to a bug in the Profile site, I was unaware that I had purchased WinClone 6 last year.) I wanted to get a clone to test the migration with before I did it onsite live, and WinClone 4.4 was what I had on-hand, and so a 4.4 Block clone was what I got. When I got home, after finding out that I in fact had purchased Winclone 6 as I had thought, I set about converting the 4.4 Block clone to sparse image and then to 6.2.2 WIM to “shrink” it. I restored that shrunken WIM backup and a Win10 Pro backup that I’d made from the donee iMac to the donee iMac multiple times, interchangeably, without fail, booting from a 10.13.6 USB3 SSD. “Yay, I’m ready!” I tragically thought.

[During the week, and before I realized I had WinClone 6, I saw that WinClone 7 was 50% off so I bought it. During that process I realized I already owned 6, thanks to a saved password in Safari and iCloud Keychain. This would turn out to be A Bad Thing.]

So on Saturday, I set out to do an iMac-to-iMac clone, thanks to the new feature advertised in WinClone 7. I’d even bought a Thunderbolt-to-Thunderbolt cable for the occasion. It failed. An inauspicious start. (Turns out I was bitten by a bug already mentioned in another Topic whereby how sizes are calculated prevent cloning from a larger NTFS volume to a smaller, even if the contents would fit.) Gah. So I dropped back and decided to expend the extra time to backup to a file and then do a Restore, set it to run and left to do other errands. The Backup went fine… remotely logging in via VPN, I thought, once again tragically, “This is going to go smoothly!” Yet the Restore failed. The iMac kept booting into a Blue Screen of Death saying that Windows was missing something important and it needed repaired. I think the error was 0xc00000ff. (I don’t have another Late 2013 to test with, but I will shortly once the clone I did “proves” itself and can clarify then.) No amount of restoring or Set to Legacy boot or EFI boot machinations worked. I tried to restore the Win 10 Pro image, No luck. I tried to restore the prior Win 7 Pro image, no go. I completely wiped the drive and re-created the partitions. No go. I even did a full Block clone (which of course takes a while), converted it to sparse image (which takes a while), WIM’d that (which takes a while), and attempted to Restore… FAIL. I left the office around 8pm, in shame, and with a VERY unhappy girlfriend who was not going to get dinner from a nice place.

When I got home, I went back and spent another few hours Saturday evening (see aforementioned “very unhappy girlfriend”) trying various things to get Windows to boot. Just. Would. Not. I was defeated.

Sunday morning, I just –could NOT– let it go. And on a whim, I uninstalled WinClone 7.3 and re-installed WinClone 6.2.2 and attempted the Restore. It worked. I was flooooored. I restored the prior Windows 7 Pro clone. It worked. I did it three times. It worked it worked it worked. Uninstalled, re-installed 7.3, failed with BSOD. Restored with 6.2.2, worked. Early Monday I deployed the new iMac, as planned.

So… there is SOMETHING up with 7.3 and how it either Restores or sets the boot environment after Restore that 6.2.2 is doing “right”. As mentioned, I don’t have the donor Late 2013 iMac yet to re-attempt and test. But I will, likely later this week. I’m technically proficient and willing to test for you. In my perusal of the logs from 7.3 on Sunday, nothing looked out of the ordinary. And I even had disabled SIP, for good measure, though that did not make a difference. I’m regretting my decision to spend on the upgrade to WinClone 7, it was a total failure to perform, however I’d like to see it improve. If WinClone 6 can do it, I’m certain 7 should be able to. And I have 2 more iMacs and a Mac mini to upgrade with SSDs.

1 Like

thanks for the details explanation. I’ll be testing and following up soon.


This was very helpful. I managed to track down the issue and believe I have resolve it. We will do full QA testing on it next week, but here is a build that has the fix in it:


Thanks, Tim… I have the other iMac now, so I can test with it next week once I get the new SSD installed.

We were able to replicate this on 2 Macs at the office and it seems to affect Mac models that can boot legacy and EFI (generally 2012-2014) and are restoring Windows 7. In this case, the Volume Boot Record is not restore and this prevents legacy booting (and Windows 7 doesn’t reliably EFI boot).

It should be fixed in the build I linked to above. Let me know what you find out and thanks for the detailed bug report. Please send me your TShirt size to support@twocanoes.com as well as your address, and we will get you official Twocanoes swag.


Hi, tim,
This weekend I was able to test and successfully restore all of the images (2 Win7 and 1 Win10) I’d made prior using the build you’d linked. So looks like you squashed it!

Did the Mac-to-Mac Clone feature bug (smaller target space calculation causing failure before attempt) get squashed too? I have another iMac SSD upgrade I’m doing next week, doing a clone would be quickest, though not required.

Yes, both issues were resolved.