Problem Booting Windows 10 with Boot Runner 3.1


#1

Probably not an issue with Boot Runner per se, but it would be nice if I could get it to work.

Replaced Fusion drive with an SSD on a 2015ish 27" iMac. Left the small SSD part of the Fusion drive in the machine, Disk 0. Installed High Sierra on the new SSD, Disk 1. BCA is unhappy about this arrangement and refuses to help, so I formatted the small SSD and installed Win 10 manually. All is well, except that Boot Runner displays the Windows drive, lets you select it, tries to restart into it, but fails. Boots back to macOS and lands at Boot Runner screen.

Hoping someone can confirm my suspicion that the drive configuration is not going to work. I can still Option-boot into Win 10 or macOS with no problems, just not with Boot Runner.


#2

If you can option boot to it, boot runner should work. You might have to select force efi or legacy in the settings to get it to work. Does it show up in Startup Disk prep pane?

tim


#3

Both volumes show up in startup system prefs, and I can boot either one that way. I’m unfamiliar with where to select efi or legacy on a Mac.


#4

Log on to https://profile.twocanoes.com and create boot runner config. Under Other Options, there is a “force boot type”. Download the profile and double click to install.

tim


#5

Tried each of the three force boot options. Exactly the same symptom. Can select Bootcamp drive in Bootrunner, machines restarts with the audible bong, screen stays black for maybe 15 seconds, then restarts back to Bootrunner screen. Can option-boot to Windows just fine.

I’m thinking I might have to install macOS on Drive 0 and let BCA setup Drive 1?


#6

I would also investigate using bless on the command line to try and see if you can select them to boot, since that is what boot runner relies on to set the boot disk.

tim


#7

Tim,
I am having the same problem as thisispaul2. I only have one hard drive on a late 2012 Mac mini and I have new installations of macOS 10.13.6 and Windows 10 on the drive. I can not boot into Windows 10 using boot runner. I followed the directions and have exhausted every option to this point.

Things tried:
I did make the changes to SIP for NVRAM. I can change the boot drive from the command line with bless and in preferences. I can option boot into both macOS and Windows. I created a profile online and tried all of the force boot options, drive names (BOOTCAMP, disk0s4) and resetting plist after removing profiles.

Still no joy.

Lee

UPDATE:

I used the uninstaller to remove the application and started over from scratch. Problem solved!


#8

Hi,

I’m struggling to get BootRunner to boot my external Windows 10 installation, I can bless the volume via terminal [sudo bless /usr/sbin/bless -device /dev/disk3s1 -setBoot -nextonly] and it works fine.

I’ve set SIP to csrutil enable --without nvram
I’ve tried all 3 options in the force boot type, EFI, Legacy & Volume EFI

but no matter what I do it just doesn’t work, I’ve uninstalled and reinstalled as the suggested fix, still no joy.

Running 10.14 and Boot Runner 3.1 if that combination has any bearing on the solution.

I’d be grateful for some advice on what to try next