Resizing Bootcamp partition, now won't boot/EFI

New user, attempting to correct a problem I have created today. Sorry if this is outlined elsewhere, but I couldn’t find it.
Bootcamp partition needed to be enlarged, but I didn’t want to have to reinstall Windows 7, etc.
Read and watched some YouTube videos how to do this. Bootcamp worked fine before this, by the way.
Ran Disk Utility, created additional partition.
Was thinking I needed to format MS-DOS, so I deleted the new partition, started anew.
Created partition without issue. I intended to reboot into Windows, use Mini Partition tool to delete and merge Bootcamp partition with the newly-allocated free space.
However, won’t boot with BootCamp now.
Read that I could use WinClone to make the EFI partition bootable, which had solved another person’s problem - can’t execute that feature in WinClone 8 without paying $40 for the software (which I would happily do, if I could be confident that would fix the problem).
Hoping this is an obvious situation that an expert could immediately recognize!

Mac OS Mohave
MacBook Air - 2012
256GB SSD, BootCamp 50GB

As well, the Mac sees the Bootcamp partition in the startup disk preference pane, but says “non-bootable drive” when I try to boot there. Also, selecting Option when rebooting the mac, only the Mac HD shows up as a viable boot option (windows has disappeared).

We have a very friendly refund policy so buy it and give it a try. It it doesn’t work, we’ll refund your purchase: