Restore error copying BCD to Windows partition

I have been using Winclone 5 since January 2016 (El Capitain, Windows 10, Macbook Pro Retina 2012).
Each time, after restoring a disk image, I would set the Boot Camp partition to “legacy boot” in Winclone and everything would work fine.

I recently updated the Macbook to High Sierra.
Windows/Boot Camp has continued to boot and function without any problem…
However, a couple of days ago I needed to restore the last saved Winclone image… Winclone 5 wouldn’t run.

So I bought a copy of Winclone 6 (Standard), but now the restore fails just towards the end - “Restore Error. Could not copy BCD to Windows partition. This version of Windows may not support legacy booting”.

I am now completely stuck as I have no Windows computer. I hope that you can help me.

I see that you wrote into support. I responded there, asking for the logs.


Thanks for responding to my request…
I think I have solved the problem (as follows):

I tried to restore the image - stops at the error as mentioned. In Utilities, set boot to EFI.
Boot holding down option key and choose EFI drive (won’t boot Windows any other way).
Windows had loaded, but with various problems such as audio devices missing, no control over brightness and other options.

Booted into OS-X and saved Boot Camp partition as new image.
Tried to restore an old image - failed as before…
Tried to restore the new image I’d just saved - success. The audio devices now worked, also brightness and other options.

I guess, to avoid all this hassle, the way to do things would be as follows:
BEFORE updating OS-X, restore Windows image using Winclone 5.
THEN update OS-X to High Sierra…
THEN update Winclone to version 6…
THEN save disk image from Boot Camp partition.

Fingers crossed now!