Restore Error: Error Mounting EFI

#1

I’m currently trying to restore a bootcamp image on my Macbook Pro 2018 15 inch onto an external SSD (I couldn’t do volume to volume cloning due to Block Size Mismatch). When restoring from image, I come come across the error: “Error mounting EFI” and can’t complete the restore.

I have checked for Antivirus softwares and such and dont have any of them running. I also made sure that my SIP is disabled.
I tried to mount EFI with the command: “diskutil mount disk0s1” which gives me the error: “Volume on disk0s1 failed to mount
If the volume is damaged, try the “readOnly” option”

However, when I do this with sudo with the command: “sudo diskutil mount disk0s1”,
I can properly mount the EFI without issue and also was able to create a folder inside the EFI folder.

I tried running winclone again to restore the image on to the ssd while having the EFI mounted, I still get the same error saying “Error mounting EFI.”

Is there any workaround so that Winclone can appropriately mount the EFI and do its job?

0 Likes

#2

I was able to solve this issue by dismounting the BOOTCAMP drive (from the original partition that I created for the clone). Winclone was able to suddenly read the EFI when this was done.
Now Im facing another issue with the Inaccessable Boot Device. Ive tried the Recurse method using the recovery disk, but I still havent been able to resolve this issue…

0 Likes

#3

So you followed this article successfully and it still does not work?

tim

0 Likes

#4

I couldnt get it to work. Despite injection I kept getting the same error.
I instead went with the Migrate Windows 10 to an External Drive (https://twocanoes.com/knowledge-base/migrate-windows-10-to-an-external-drive/), and had good success. Thanks. I think it was the Sysprep step that changed my outcome.
However, I have 2 questions. After removing the bootcamp partition with disk utility (I was wondering why the guide said disk utility instead of bootcamp assistant but I followed it anyways), I booted the macbook pro with the option key pressed. I get 3 options: Windows, Macintosh HD, and EFI Boot. Selecting Windows or EFI Boot boots the windows from the same external SSD that I have attached.
I’m wondering if this is supposed to be behave this way, or is there any safe way to get rid of one of the options; Windows or EFI Boot and just have Macintosh HD and Windows (or EFI Boot, either or).

Also, 1 other question: Is it safe to encrypt this external bootcamp drive with bitlocker? (I understand that Winclone can no longer back it up, but was wondering if its a possibilty).

0 Likes