Restored bootcamp to same machine not booting

I am on a MacBookPro 13" 2017 with 1TB internal apple SSD.

I was running windows 10 build 1903. As backup before experimenting with updates I made a clone of the bootcamp volume I made 2 clones:

  • normal format
  • block based format

Then I upgraded to build 2004 insider DEV build of windows 10. Again I made a clone of the bootcamp volume in normal format.

After some tries with driver updates Windows crashed and became unbootable so I wanted to restore the 1903 image.

  • the block based image requires 104 GB but the partition only has 103 GB. This is very strange as I did not touch the partitions.
  • the normal image I could restore but it is not bootable. Windows gets stuck with a black screen with some text that it cannot be bootet and one should get the windows installer

So the entire purpose of the backup has failed! I don’t think the inject apple SSD driver could be solution because I am on the same machine, same SSD, no hardware changes!

Then I went on to restore the 2004 windows clone and luckily it worked and it was bootable. So I still have a working windows configuration. However, I’d rather be able to go back to 1903!

What could be the reason? Also very strange that block based restore failed to the same volume…

Kind regards,

that is strange. It should not make a difference between the two builds. I’ll do some testing in our lab.


Thank you! Any idea why the block based does not work claiming the volume is too small - I cloned it from the same volume after all ?

So you did not re-create the partition and restored back to the same partition? If that is the case, then Winclone should not have given that error.


Indeed I did not touch the partition at all. I simply restored the previously saved partition on the same device.

Now I am on a new MacBook 2020 and tried restoring my old windows bootcamp. Even when injecting the AppleSSD driver it did not work. I proceeded with a fresh install.

I am starting to wonder if using winclone for safety is a good idea. So far I could restore 1 backup out of 4 tries…

Same machine:

  • 1903 windows block save: partition was a few MB too small (same partition!!)
  • 1903 windows WIM: windows did not boot
  • 2004 dev insider build: worked ok

New machine

  • 1903 windows WIM: windows failed to boot with black screen, white text boot device access error. Installing AppleSSD drivers did not help

so quite negative results so far :slight_smile: