Restoring windows 10 fails to boot


I got Winclone 9 a couple weeks ago and now I’m just tired. I bought a new MacBook Pro (Intel 2020), and I’m trying to transfer my Windows 10 Pro bootcamp instance from my old MacBook Pro 2015. I’ve been trying to get it to work, but so far I’ve just been able to create the image off the 2015, as every time, something goes wrong. I already had exchanged the new Mac thinking maybe something was wrong with its SSD drive (oh and UPS lost that on its way back to Amazon while I’m on the hook for like 2 grand but I digress) and yet still, the new new one can’t advance further than:

  • List item

showing me the Windows 10 logo, then

  • List item

showing a blank blue screen, before

  • List item

rebooting back to macOS.

I have not upgraded this new Mac to Big Sur because I figured that’s how I had my troubles last time. But at least in Catalina, it seems like I’m further along than how I was with Big Sur. lol

At first I tried to just wing it by doing a backup and simple restore off the software, then I turned off the T2 secure boot stuff and that only helped a little, then I started all over and followed the instructions from Two Canoes YouTube page based on migrating from 2013 to 2019 because I figured that might be similar, but I followed everything, including the whole “support drivers” and side booting through a Windows 10 installation with boot camp drivers, again and again, and nothing.

Please help me as I don’t want to lose my software licenses and have to rummage through my stuff from like 5 years ago. Having to move and setup everything is basically what I wanted to avoid, but this is becoming too much. I also personally don’t wanna have to deal with your seemingly cumbersome refund process, no offence. lol but also seriously, I need this new computer for remote work.

Thank you!

Look, I know a bit about how to do this on a regular Windows 10 PC with EFI Secure Boot and can deal with situations like backing up and restoring from a Windows 7 Backup Image then facing a BSOD, then subsequently resolving that with like boot record bcd rebuilds and junk; I can migrate, partition and clone and extend Windows partitions using parted, etc. But for some reason, this T2 stuff just doesn’t like my usual tools! And the whole lack of USB-A ports in favour of thunderbolt 3 stuff, plus the touchbar and useless trackpad plus the lack of wifi networking support while in windows recovery model just makes this 100x harder.

Please help me. I beg you! I’m about to cry hysterically as a grown ass man. This has all just been way too much trouble, and I’m starting to think I should’ve just went with a Surface Book because I only got this nearly 2 grand computer (4 grand if Amazon refuses to accept my return that UPS lost :rage:) instead of a newer M1 Mac because I needed Bootcamp, which is now about to be useless to me anyway!

Please and thank you. :pray:

Okay I was JUST able to resolve this as of 30 minutes ago. Took me a long time though. Like right now it’s past midnight. :stuck_out_tongue_closed_eyes:

Someone should mention somewhere that doing this would require uninstalling all the Intel software in the existing image and also uninstalling BootCamp using a Microsoft fix-it package. Then install the Windows Support software bootcamp setup.exe file off the USB drive. Really, not doing this would prevent Windows from starting in “full secure boot” mode because of some device hardware conflicts. After doing this and everything is resolved, I was able to turn on the Secure boot settings from the recovery partition and block USB boot mode. I did not have to reimage again, I just continued using the original reimagine from Winclone 9 I described yesterday.

Now I’m able to use my old Windows 10 image from my old 2015 MacBook Pro on my new 2020 MacBook Pro securely! :+1:

1 Like

Hello Johnrm,

I am so happy that you were able to make it works. I spent lots of time on it myself. I would like to try again with my failure bootcamp. I am appreciate if you can please provide me detail steps how you did on the “uninstalling all the Intel software in the existing image and also uninstalling BootCamp using a Microsoft fix-it package. Then install the Windows Support software bootcamp setup.exe file off the USB drive.” Also, how you turn on the Secure boot settings from the recovery partition and block USB boot mode.

Stay safe and healthy!

Many thanks,

Hey Warren,

Just FYI unfortunately you can’t turn on Windows Bitlocker Drive Encryption after restoring. Even though everything was working, I tried to activate bitlocker but when it restarted to try to encrypt my Windows volume, it gave me the BSOD.

With that in mind:

First try logging into the recovery partition by doing shutting down then turning on and quickly pressing and holding command - R until the Apple logo screen flashes red or something.

Login to the recovery, then from the recovery menu, open Startup Security Utility.

Choose the options to both turn off secure boot (“No security” I think) and turn on “Allow USB boot mode” or something like that.

Follow the prompts to restart back to your Mac. It will ask you to give it your macOS password before restarting.

The next time it restarts, assuming you already have the Windows software and WindowsSupport software setup from bootcamp, along with the additional stuff from Two Canoes (like a batch script I think, and you have to also copy and paste some stuff, but MAKE SURE you still have the exact copy of the WindowsSupport folder you generated from the BootCamp app in macOS, they have the instructions for that somewhere on the Two Canoes support site), hold option then boot into EFI boot.

Once you’re in the windows 10 installation screen, if you followed the instructions from the TwoCanoes support page for that recovery drive, you should have access to the function keys (but it will take a bit until the drivers get registered by Windows). Press and hold Shift, Fn, F10 to open command prompt. Then execute the batch script while still in the Z: drive path. (I don’t remember the name but make sure you reference the C: drive. The batch script starts with “fixinstall… .bat” I think lol :joy: can’t remember exactly)

It will restart automatically once that batch script is done. But you’ll see the blank blue screen.

When you press enter from the blue screen, you’ll see it’ll try to restart again, but when that happens, press and hold option so that you can boot back to macOS.

From the login screen, shut down macOS completely.

Reset the NVRAM by pressing the power key then quickly pressing and holding option - command - P - R while it starts. Don’t let go until you see the Apple logo go away and come back.

Shut down the Mac from the macOS login screen again.

Turn it back on and press and hold the option key until you see the boot options. This time, boot into Windows. It should start Windows this tome (but you’re still not done so keep the USB thumb drive in there).

Once you’re in Windows, your mousepad, keyboard and function keys should all be working. Open a browser and download

the troubleshooter from the Microsoft website here: Fix problems that block programs from being installed or removed.

Run that, and choose to force to uninstall BootCamp from the prompts of the troubleshooter.

From the Windows search bar, search for and open “Control Panel”. Make sure that BootCamp is not listed. If it is, select it and the uninstall button should be clickable now. Click on that. A pop up would say something like this software is already uninstalled and clicking OK should make the BootCamp go away.

Open Add or Remove Programs (the classic Windows 7 GUI, not the fancy modern UI one lol)

Uninstall anything that says Intel on it, especially the drivers. You will need to do this one by one.

Now open explorer and navigate to your USB thumb drive’s Windows Support\BootCamp folder, then run setup.exe. Install BootCamp drivers from there.

Once that’s done, restart.

Log back into Windows again.

From the start menu, search for and open Control Panel again.

From there, search for and open Device Manager, the classic Windows one.

Check for any driver issues. Since you uninstalled the Intel drivers already, there should be none.

But, if you see any unresolved device (with a yellow triangle icon or something), uninstall it from the Device manager, but do not try to refresh the Device manager afterwards (otherwise the driver issue will come back!!!), then try uninstalling whatever the driver is from the Add or Remove programs again, and just to make sure after, run and complete the WindowsSupport\BootCamp\setup.exe again.

Restart again, log back into Windows again, and repeat that Device manager stuff again until everything is gone.

Now boot back to the recovery drive and turn on Full Security boot (only allows boot to Windows and macOS) and turn off USB boot mode from the Startup Security Utility again.

You should be good from this point, as long as you don’t choose to try to activate BitLocker Whole Drive Encryption. That would mess you up and as far as I can tell, there’ll be no way to fix that BSOD. The plus side is that your Windows side can only be accessible via macOS. The downside is you are vulnerable to the T2 chip checkm8 vulnerability and a malicious person who has access to your device can essentially inject a keylogger to wait to obtain your password, then use it to get past your macOS FileVault Encryption and turn off secure boot from the recovery OS, and at that point it’d just be way too easy to reset your Windows password via the SAM from unix or Linux with a live USB and chntpw, and that’s just very bad. But the risk of that is low unless you work in healthcare or government anyway and travel around anyway.

Unfortunately I couldn’t get around that because I do work in a “security safety sensitive” sector where the rules about that were like “codified” by the appointing authority, and I was just not about to risk getting fired and disavowed and homeless and unemployable during the global pandemic lol so I chose to ultimately start bootcamp from scratch and installing software one by one, which was a pain in the butt for two days but ended up being much more worth it.

Good luck bud!