Running MDS inside recovery partition errors immediately

After running the initial command, I only ever get the below. I’ve tried on 2 computers. One a 2017 iMac and a brand new 2019 iMac I opened this morning. For the MacOS installer, I used a just downloaded Mojave installer from the App Store.

I see some reference to other users having this issue before but my recovery partition is updated to the latest on both computers.

-bash-3.2# /volumes/mds/run
Network is up
Starting up Imagr, please be patient…
Installer and package logs in /var/log/install.log
Open a new terminal window and run “tail -F /var/log/install.log” to view
2019-10-11 13:43:02.218 Imagr[684:44548] TISFileInterrogator updateSystemInputSources false but old data invalid: currentCacheHeaderPtr nonNULL? 0, ->cacheFormatVersion 0, ->magicCookie 00000000, inputSourceTableCountSys 0
Keyboard Layouts: duplicate keyboard layout identifier -14934.
Keyboard Layouts: keyboard layout identifier -14934 has been replaced with -28673.
2019-10-11 13:43:13.575 Imagr[684:44595] Macintosh HD
2019-10-11 13:43:26.606 Imagr[684:45006] *** Terminating app due to uncaught exception ‘OC_PythonException’, reason: ‘<type ‘exceptions.KeyError’>: ‘FilesystemType’’
*** First throw call stack:
(
0 CoreFoundation 0x0000000106645e39 __exceptionPreprocess + 256
1 libobjc.A.dylib 0x00000001044a43c6 objc_exception_throw + 48
2 CoreFoundation 0x000000010665fc91 -[NSException raise] + 9
3 _objc.so 0x000000011311821e PyObjCErr_ToObjCWithGILState + 46
4 _objc.so 0x00000001130fa190 method_stub + 5936
5 _objc.so 0x0000000113138f30 ffi_closure_unix64_inner + 688
6 _objc.so 0x000000011313843e ffi_closure_unix64 + 70
7 libsystem_pthread.dylib 0x000000010ba5e2eb _pthread_body + 126
8 libsystem_pthread.dylib 0x000000010ba61249 _pthread_start + 66
9 libsystem_pthread.dylib 0x000000010ba5d40d thread_start + 13
)
libc++abi.dylib: terminating with uncaught exception of type NSException

This is most likely due to the version of the recovery being too old (MDS requires 10.10 or later). Check by running sw_vers in Terminal in Recovery.

You can get a newer Recovery by using Option-⌘-R:

tim

Hi Tim. Both have the 10.14.5 recovery partitions. As I said, I tried this on another 2019 iMac that was just purchased from Apple, fresh out the box and wrapping. Same error.

Hi Andy,

Try opening disk utility and erase the drive first. Then run the MDS run command. I found that gets me past the errors.

Adam

Okay I finally got it to work. I did what zoocropolis suggested and wiped the drive first before running the command but that still didn’t work.

What actually ended up working for me was preparing another disk with MDS. The disk that I was initially using had two partitions on it. One that I had prepared with MDS and another partition with some files on it.

Seems that the two partitions were conflicting with each other.

Thanks for your help guys.

1 Like