SD Clone crashed while writing to my SD card, now the card is toasted

Hi, I have the pro version and on Mac Mojave 10.14.6 the restore seems to have entirely crashed my laptop.

Since then the sd card is unusable/toasted. I tried to fix/format the partition on windows without success there either.

Even starting SD Clone while the SD card is connected is giving trouble (SD Clone freezing on start).

I tried to erase and reformat via the command line with diskutil without success, the error message is that it is unable to unmount.

sudo diskutil eraseDisk ExFAT card /dev/disk2

Is my SD card fried, is there any way so fix it?

Thank you.

SDClone uses the command line tool “dd” to write blocks to the card, so there is no way it can physically damage it. I am surprised that formatting fails in both Windows and macOS. I suspect there is a problem with the SD Card itself.


Thanks Tim, I decided to order new SD cards in the end.

I am a bit surprised as I tried the Windows IoT for Raspberry Pi tool to flash the card (tested it a few minutes and was quite disappointed in windows on RPi 3B). Then wanted to restore with SD Clone and that is when the card was affected.

Thank you for the response, I guess I will simply move on with a new card.

Pier-André Maynard