Shrink Not Working


#1

I just purchased SD Clone today. This seems to be the tool I need. I have a 32.01 GB RPi that I want to put on a 31.91 SD card so I have a working backup. I followed the YouTube video instructions for making the safe copy. I saw a similar message and you asked for the diskutil list results:

/dev/disk3 (external, physical):
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *32.0 GB disk3
1: Windows_FAT_16 RECOVERY 1.3 GB disk3s1
2: Linux 33.6 MB disk3s5
3: Windows_FAT_32 boot 69.2 MB disk3s6
4: Linux 30.6 GB disk3s7

Help?


#2

From the output, it looks like it should work to shrink. What error message are you getting?

tim


#3

Tim,

On my first attempt to reply I received this message:

We’re sorry, but your email message to [“twocanoes+4938e4cac476da951b57a223d9c9fd7e@discoursemail.com”] (titled Re: [Twocanoes Forum] [SD Clone] Shrink Not Working) didn’t work.

Reason:

Sorry, new users can only put one image in a post.

If you can correct the problem, please try again.

So I removed the images from SD Clone. Basically the image shows the dialogue box to Shrink, I clicked OK and it (quickly) says “Shrinking” but never shrinks (no error message). I’ve left the image of the results of my df command. See below.

Thanks,

—Lloyd


#4

I’ll set one up and try to replicate the issue.

tim


#5

Hi the same goes for me, trying to shrink a 16GB uSD card from SanDisk into a smaller 8GB card so I can burn a Debian image and then extend this with some more apps on the Beagle.
I then want to make an image and use that as a base for other installations.

Selecting a formatted 16GB card and then pressing Shrink does not shrink the card. Is this supposed to work?

Edit: What did work after watching the Video, is saving the master SD card first, size does not matter. The saved zip file can than be used to reproduce on the Mac with SD Clone, or on a Windows machine with Etcher. I’ve tested this on a BeagleBoneBlack with a 16GB Sandisk. All and all a matter of reading the manual first :slight_smile:


#6

@mvhall solution does not work. I’m trying to clone and shrink a Raspberry PI 32GB card which came with my original kit from canakits, so that it will fit on a 8GB card. On this card you have two main partitions RECOVERY, and boot.
Trying to shrink from the card itself or from a created image does nothing.
I paid 40 dollars for this software because I thought I would be using it a lot, but it doesn’t work for modern Raspberry PI filesystems on SD Cards.


#7

Hello,
I just bought SD Clone basically for being an easy way to shrink SD Retropie cards so that I could clone on smaller cards but unfortunately it does not work.
When I select one of the two shrink option on the menu (yes, theres two of them there somehow) one does not do anything the other does a sound as soon as I select the option but there’s it.
I tried shrinking the sd card after making a full backup, I tried shrinking the .img itself, only the Retropie partition but it does not work.
Anyone knows what else cloud I tried?
Thank you!


#8

Update:

I have Paragon extFS form Mac installed and definitely SD Clone and extFS don’t play well together.
After disabling extFS the shrink option started working.
At least now I can finally my Retropie SD cards although it’s a less than ideal solution since I work directly with several ext3 drives and I need to keep enabling / disabling extFS.

Hope this help anyone with the same problem.


#9

That is very helpful. I am bit surprised that the driver caused issued, and I will do some follow up test. I’ll also create a knowledge base article explaining it.

tim


#10

I had Paragon NTFS installed on my desktop. I tried disabling it, then uninstalling it, however neither resolved the issue. I moved the license over to my Macbook pro, then tried to shrink and again it didn’t work.
Same issue you had two shrink options. One does nothing (makes a sound like it’s done), the other ask me to “visit os x fuse website”.

Update:
I believe the issue I have is with NOOBS, which is a popular way of installing raspberry pi compatible OS’s.
When I mount my raspberry SD cards I have two partitions “Recovery, and boot.” I believe this confuses SD Clone. After doing some digging I couldn’t find an easy way of getting rid of the recovery partition, and of course I’m trying to do everything in my power from having to start from scratch.
Maybe a future upgrade of this software could account for NOOBS SD Cards.


#11

Ah, that makes sense. I’ll do some testing with NOOBS.

tim