SSD Driver injection failed


I am a Winclone User for many years.
I want to install Bootcamp on my new iMac2020 on the external thunderbolt SSD.

I made a clean new bootcamp installation on the internal drive (ssd) first.
After Installing I tried a boot and installed all BC Drivers & Windows updates.

Then I made an Image File from the bootcamp partition with Winclone8 and restored this Image to my external SSD.

This SSD was not bootable (inaccesable boot device). So I tried to inject the SSD Driver from the Winclone8 menu regarding your manual.

This fails with this message: No Driver Found (but it was there)

See screenshot:

After that I tried to inject the driver from the Windows command prompt like described here:

dism /Image:D:\ /Add-Driver /driver:c:$WinPEDriver$ /recurse

But this operation failed again.

Message was something like:

In my case there was no drive “D:”
I changed the D: to X:

dism /Image:X:\ /Add-Driver /driver:c:$WinPEDriver$ /recurse

“you tried to modify a installed Windows”

I have no idea what went wrong.

Any hints?

I tried now with the latest Beta from here:

And the Driver Injection was successful (as Winclone9 reports)

But I get still a bluescreen with this:

I would say the SSD Driver is not working for the new iMac2020.

OK, i ordered a 2020 iMac and will test the driver injection. It will be delivered in the next day or so.


1 Like

Any updates! Could you fix that issue?

It is fixed! Check out the current build at:


1 Like

Is this fix specific to 2020 iMacs (with T2) or could it help with inaccessible/driver problems on other hardware (non-T2 Macs and previously untested/unsupported SSDs) ?

Hello Tim,

thank you for letting me know but I still have the same issue.

I did the following:

  1. Made a Image (filebased) from my working bootcamp partition on the internal Apple SSD

2.Restored that Image to my external thunderbolt SSD (Transcend StoreJet 500 Thunderbolt SSD) which I used also with my former iMac 2017 as described in this video

  1. I injected the drivers from the Apple WindowsSupport pack with Winclone (successfull)

  2. I made the SSD EFI bootable with Wi nclone Tools

  3. I tried to boot from the SSD (EFI)

It failed again with the INACCESSIBLE BOOT DEVICE Error Message :frowning:

1 Like

Hi Tim, thank you for the reply. I am not willing to give up this early :blush:!
I read the linked article with driver injections carefully but there is a point that’s not clear for me.
I have downloaded the Transcend Driver for my ext Thunderbolt SSD and copied it to the windows boot stick which is made like described in the article.

This part isn’t clear:

1. Typically, the USB Flash drive is assigned C: and the internal drive is assigned D: when booted from the USB Flash Drive. Verify drive lettering by entering in these commands and verifying correct driver letter assignment. If the drive letters are different, adjust the dism command below to use the correct lettering. On C: you should see a WinPEDriver folder (and other items) and on D: you should see a Windows folder and Users folder (and other items).

> dir c:
> dir d:

2. Inject Windows drivers by running the following command (note that there is a space before every forward (“/”) slash.

dism /Image:D:\ /Add-Driver /driver:c:$WinPEDriver$ /recurse

Do you mean to inject the driver into the winclone image or my running bootcamp partition on internal ssd?

I have tried another way.
Loading the ssd driver after booting from windows install bootstick.
I wanted to continue the windows setup then but this failed…

In my case C: is the boot stick and d: is and external usb drive with the winclone image (filebased) and X: is the boot camp partition on my internal ssd (which runs fine).

I tried to install the transcend driver with drvload which was successful (message in dosbox) but I still can’t see the tb Drive after that!

Could you please explain how to do the inject steps correctly?

Thank you!

Interesting. So you see the thunderbolt drive before you use drvload or it removes it after injecting? I would expect it to not show until after you used drvload.