Sysprep fails. Log file says it's because of package Windows.MiracastView. Here's how to fix


#1

So you’re trying to clone your Windows install on your Mac, and you’re following the WinClone instructions. But SysPrep has failed for you, and the log file says this is the reason:
Windows.MiracastView_6.3.0.0_neutral_neutral_cw5n1h2txyewy was installed for a user, but not provisioned for all users

By spending a LOT of time on Google, I have found many sources that claim to fix the issue, but actually don’t – including Microsoft’s own “help” desk. I have cobbled together, using those various resources, a method that should work to fix this issue… At least it worked for me… Your mileage may vary.

  1. Download the file located here: //drive.google.com/open?id=1Qrdf_2IiQTX-t6tmwMHnvdzB5RXmFQop

  2. Unzip that file and copy the MiracastView folder into your C:\Windows folder.

  3. Now go here: //docs.microsoft.com/en-us/sysinternals/downloads/psexec and click on the “Download PSTools” link near the very top.

  4. Also go here: //sqlitebrowser.org/dl/ and click on the link that says “DB Browser for SQLite - 64-bit Windows”

  5. Extract psexec.exe from the PSTools.zip file that you downloaded earlier. Put it anywhere you like, just remember where you put it.

  6. Install the DB Browser for SQLite program by double-clicking on the .exe file you downloaded in step 4

  7. open an Command Prompt AS ADMINISTRATOR.

  8. run the psexec.exe program by CD’ing to the folder in which you put the psexec.exe program, and typing the following: psexec.exe -i -s -d cmd.exe

  9. in the new command-prompt window that will open after you have completed step 8, type the following WITH the quotes: “C:\Program Files\DB Browser for SQLite\DB Browser for SQLite.exe”

  10. Click the Open Database button at the top and open the following file: “C:\ProgramData\Microsoft\Windows\AppRepository\StateRepository-Machine.srd” (You probably won’t be able to browse there, so just copy and paste what I put INCLUDING THE QUOTES into the filename box).

  11. Click on the Browse Data tab, and change the table to Package

  12. Look under the PackageFullName column for Windows.MiracastView_6.3.0.0_neutral_neutral_cw5n1h2txyewy and change the value under the IsInbox column from a 1 to a 0 (Make sure to exit that box after you have changed the value in it – click on another box or press enter or press tab, whatever you want)

  13. Click on the Write Changes button at the top to save the file.

  14. Close the DB Browser. Close the command-prompt windows.

  15. Open Power Shell AS ADMINISTRATOR. (Press the Command key, type “power” – no quotes – right-click on the Power Shell that should be displayed, select Run As Administrator)

  16. Make sure you’re in the \Windows\System32 folder inside Power Shell – if you’re not, change to that folder by typing “cd \Windows\System32” (without the quotes) and pressing return.

  17. type the following command: get-appxpackage -allusers | where {$_.name -like “mira”} | remove-appxpackage

  18. Hopefully step 17 executed with no errors. Assuming it did, reboot the computer. If it didn’t… Well… Maybe you missed a step above?

  19. After rebooting, if the C:\Windows\MiracastView still exists, delete it.

  20. Now run SysPrep as instructed by the WinClone instructions. It should work, and you should now have a SysPrep’ed Windows volume that you can clone properly.

This was a crazy stupid error caused by a bug when Microsoft issued the update from version 1703 to version 1709 of Windows 10. Beyond ridiculous…

Here are the websites I used to cobble together this method of fixing this error, so you can peruse them yourself, should you so desire.

//support.microsoft.com/en-us/help/4057974/miracastview-cause-sysprep-error-windows-10-version-1709
//www.linkedin.com/pulse/how-beat-windows-10-1709-miracast-view-error-benjamin-blacklock/
//alexappleton.net/post/159702702033/windows-10-pro-remove-wireless-display-media

Hopefully, if you’re having this issue, you’ll find this post and not have to go crazy trying to figure out a solution like I did. Best of luck!


#2

thanks for posting this.

tim


#3

There are some users who have encountered an issue with MiracastView, the time they install a large update on Windows 10. In case you want to go in detail then visit this webpage https://appuals.com/fix-miracastview-error-after-upgrade-on-windows-10/ This issue pops up when the user installs the Fall Creators Update or to run a Sysprep command. This issue is because of a bug that reasons the upgrading setup to badly migrate the Windows. MiracastView 6.3.0.0 neutral neutral cw5n1h2txyewy. No need to be anxious because we have some methods to sort out this issue.

1- Copying the previous MiraastView folder into the present Windows directory: Users can access the backup that has the old build, copy the old C:\ Windows \ MiracastView folder, paste it in your existing C:\ Windows directory and reboot your PC. This will complete the purpose of letting the background AppReadiness procedure to remove the package files that were migrated wrongly.

2- Removing a leftover registry key that is causing the issue: Tap the Windows key + R to open up a Run box, write “regedit” and click Enter to open up Registry Editor. Go for the following key: HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Appx \ AppxAllUserStore \ EndOfLife \ and enlarge each SID and look for the Windows.MiracastView_6.3.0.0_neutral_neutral_cw5n1h2txyewy key. In case you spot it in any of the sub-keys of EndOFLife, tap Delete to erase it. Now exit from the Registry Editor and reboot your PC. At the next startup, create the similar scenario in which you before received MiracastView issues. This error would probably be solved now.