Trail Boot Runner user - Windows Legacy detected, doesn't boot

Hi,
Mac pro 5,1 2010 144.0.0.0 latest firmware
Mojave running on a SATA SSD A
Windows 10 1909 installed in BIOS/Legacy mode on SATA SSD B
SIP disabled altogether, the –without nvram option was giving errors (unsupported configuration, etc)
Automatic login disabled, user/password option selected in SysPref.

Boot Runner does detect the Windows partition, however, after selecting it just reboots back into the Boot Runner login window.

I tried creating a custom profile choosing force Legacy, but it did not help.

Surprisingly, both bootCHamp and Quickboot free utilities work just fine booting on the very same Mac Pro into Windows. I understand Quickboot uses exactly the same concept minus Boot Runner aesthetics (which I prefer). I of course uninstalled Boot Runner first to avoid any potential conflict.

Could you please help me troubleshoot. Do I ned to create TWO profiles, one for the macOS and a separate one for the Windows 10, enabling force Legacy for the latter?

Could you kindly respond promptly as the trial countdown is ticking.

Thanks

The very same (mis)behaviour before upgrading to Mojave, but then I saw Mojave/Catalina in the requirements for Boot Runner so I attributed it to that. Same story with Mojave, unfortunately, as described above.