Trying to clone to external drive, block size issues, won't boot

I’ve been following your guide re migrating windows to external drive.

All starts out great - I’m able to format the external drive to FAT32 using GUID partition map.

I then try to “restore to volume” from my Bootcamp partition on my Mac HD to the external drive. I first need to disable SIP. Then I receive the dreaded “Block Size Issue” pop-up.

If I go ahead, it writes to the hard drive, but the result is not bootable on the external hard drive. On boot, the Windows logo comes up, but then there’s an error saying “stop code, inaccessible boot device”.

Any ideas? This looks like it should be easy!

I’m using a 2016 MacBook Pro and Winclone Standard 6.0.4.

ETA: I’ve tried manually setting EFI mode. Same behaviour.

Second ETA: I’ve tried using WIM and block-based copying, with no difference in behaviour.

External drive booting can be tricky. I use the Samsung T3 drive with Windows 10 enterprise on a 2016 MacBook Pro, and it boots fine. It is very dependent on the drive and the interface.