Trying to inject SSD driver - get Windows SYSTEM file missing error

Trying to inject SSD drivers into Bootcamp partition I get

‘The Windows SYSTEM file does not exist at /Volumes/BOOTCAMP/Windows/System32/Config/SYSTEM. Please check the disk and try again’

I have had a look inside the partition and the file is there. Then it comes up and says the drivers injected successfully, but I can’t boot from the BOOTCAMP partition without getting the INACCESSIBLE_BOOT_DEVICE error.

I have tried booting from an external drive with windows 10 and following the instructions on Inject Drivers but it just asks me to install Windows, which I don’t want to do.

Going nuts trying to work this out. Any assistance appreciated.

try opening terminal and see if that file is at that exact path by running:

file ‘/Volumes/BOOTCAMP/Windows/System32/Config/SYSTEM’

tim

Hi Tim, thanks for getting back to me.

This is what I get in Terminal:

Hi Tim,

I think I may have solved it. Just noticed that Winclone was looking for Config, when my directory was config. Just changed the directory name in BOOTCAMP to Config and the injection seems to have worked. I’ll have another go at starting from the partition and let you know how it goes.

OK, so now I’m getting UNMOUNTABLE_BOOT_VOLUME as the error when trying to start the Windows partition. What next?

The drivers were injected successfully? Can you give me more information on what type of mac/drive it is?

tim

Hi Tim, here I am 2 weeks later still having problems. I started again and followed your instructions here:


That was all good and I was able to see the BOOTCAMP partition from within IOS.

Did everything up to and including trying to run winclonefix.bat. When I did that I get this:

Error: 1005
Unable to access the image.

When I go to look at d: it says

The Volume does not contain a recognised file system.
Please make sure that all required file system drivers are loaded and the volume is not corrupted.

I would welcome any help as I feel I’m so close to getting this working and I need to access Windows software for work very soon.

Thanks, Ewan

That means that the driver for recognizing the boot camp partition was not found. You can manually inject it using:

drvload

once you inject the drive, d: should be recognized and the script should work. Try different paths to different .inf files in the Boot Camp drivers that are related to storage.

tim

Hi Tim, thanks for getting back to me.

OK, so I tried that using

drvload c:\AppleDrivers\AppleSSD64\AppleSSD.inf

That was the only .inf file I could find that I thought may be to do with storage.

And got

Unable to load ERROR 0x80070103 (according to Microsoft this is caused by trying to install a driver twice or an incompatible driver). Looks like I’m getting close but not quite.

Are there any more steps I can take? Thanks Ewan

I’ve had another look and using DISKPART I can see the partition shows up as RAW, is this the problem and should I start from scratch again?

When you boot into macOS, does it show the Boot Camp partition and are you able to see files?

It is also strange to see the EFI partition as volume 3. In macOS, can you run “diskutil list” in Terminal and send me the output? the EFI partition should be the first partition on the disk.

tim

Yes, I can see all the files on the BOOTCAMP partition from MacOS. I’m using Tuxera NTFS to be able to do that.
I ran diskutil list and this is what I got


Thanks for persevering with this, it’s driving me a bit nuts.

Ewan

If you didn’t use the Tuxera NTFS driver, does it still show the boot camp filesystem? The drvload should have loaded the SSD drive and made d: accessible.

tim

I’ve uninstalled Tuxera NTFS and re-booted into Mac OS, I can’t see the BOOTCAMP partition in the Finder any more.
When I try and mount it using disk utility I get this error:
Could not mount “BOOTCAMP”. (com.apple.DiskManagement.disenter error 49223.)
It’s still shows up as RAW when I boot from the EFI drive and I can’t get drvload to work.

I believe we discussed this via slack and it never got figured out. Let me know if you want a refund.

tim