Unable to boot from External Drive (Cloned from Internal BOOTCAMP)

I cloned Internal BOOTCAMP to External drive as per the Video of Winclone. Using Winclone 6.2. Unable to boot from the External Drive.
When I try to select the External Drive as Startup Disk from Mac, it gives error “The Bless tool was unable to set the current boot disk”.

Image is attached.

I also tried changing “Make Legacy bootable” and "Make EFI bootable"
When I select “Make legacy bootable” I get error "The bless tool was unable to set the current boot disk"
When I select “Make EFI bootable” It accepts as startup drive but it does not boot. I get another immediately after system attempts to boot.

When I try to “Make EFI bootable” and attempt to boot from external drive, I get following error.

Pressing F8 or any key after this does not help. I need to power off iMac after this.

It sounds like the external drive doesn’t support external booting. What type of drive is it? What is the interface (thunderbolt / USB)?


Dear tperfitt

External drive is Crucial MX300 525 GB SSD. I have attached it to USB 3.0 of iMac 27 inch Retina - In Transcend 25S3 Enclosure (USB 3.0 to Sata-III).

I love Winclone concept and the way it reduces the size of Backups. It is an amazing application.

I have the same issue. I have a 2017 iMac 27" with High Sierra on it using the latest Winclone 7 version. My last attempt to clone to my USB 3.0 external gave me an EFI partition separate from the Bootcamp drive and was not seen by startup as a bootable drive. Tried option booting and no Windows drive was detected either.