Unable to boot from WinClone image restore

I have a 2009 iMac 27". I backed up my Windows 10 bootcamp last March 2017 and when I recently updated my Mac OS to High Sierra it corrupted my bootcamp install, forcing me to re-install. Once I reinstalled Windows 7 I planned to use my Winclone backup image from March 2017 to get back to where I was previously. I was able to restore my image backup successfully with WinClone 6, but then when I rebooted into Windows it gave me an error saying that it was not a bootable disk. I tried to follow your guide entitled ‘Troubleshooting Windows Booting after Winclone image restore’ (https://support.twocanoes.com/hc/en-us/articles/115003306566) but this didn’t work for me. Any idea what I can do to get this image restore working properly? It sucks that I spent money on this product and am having such a hard time using it to restore my computer like it was promised to do.

Try disabling SIP and then restoring again:


I did that to restore the file initially as WinClone wouldn’t let me
restore the file without disabling it.

Do you see files on the Boot Camp partition? You can also switch between Legacy and EFI:


I ended up reinstalling from scratch, if it happens again I’ll look to see
if files were there but I presume they were. I tried switching between
Legacy and EFI, but this didn’t help unfortunately.

I have never been able to get Winclone to do any of the things it advertised to do. Nothing and I mean nothing. Not even install Windows using Winclone 10. Its like a product that is just a farce product.