Unhappy with Winclone - Incremental Backups - Bad Experience

So, I’m sorry to come here to complain, but I’m a bit upset.

First, the Incremental Backup feature has absolutely no way to understand that I’m on a laptop and sometimes I’m not docked with my setup at home and my drives are not available. Every time it starts it gives me an error saying the destination is not available. I don’t mind it does that, on a desktop when a disk won’t mount and it’s always there that’s probably handy. I would love an option to have the backup just sit there and wait and be quiet until it finds the drive again. I know that’s not everyone’s use case but, it would be nice to have the option. The warnings don’t stop either, they fire off at least once every few minutes. The only solution to this is to put the backup on the internal drive, but that can take a lot of space and there’s no need to do that. No need at all. I would also suggest the icon turn red or have a red X or something to indicate it cannot find the drive which goes away when the drive is mounted.

Second, the Incremental Backup has no option to NOT run if I’m on battery power. How is this not a thing? I use my Windows partition a lot and I like to do daily backups, that’s awesome when I’m at home and plugged in. Even if I fix the above issue by putting the backup image on my main system drive (I HATE doing that as I’ve got Windows and macOS and only a 250GB SSD), I still don’t want it wasting my battery power. Again not really needed for desktops but some of us aren’t on desktops and it would be really nice to have an option for Winclone Incremental backup to not not fire off a full backup while I’m not plugged into AC power.

Thirdly, this might seem niggling but why is it that the Winclone Incremental Backup can’t seem to figure out when I next want it to back up? I boot between Windows and macOS all day. If have the incremental backup set on a schedule, every day at 5am. I’m not using the computer, I’m almost always home and plugged in / docked with the disk drives, you get the picture. Every boot though it fires off another backup routine. Every. Single. Time. So I end up having it backup the windows partition about 10 times a day. This is tiring, sometimes I’ve only booted into macOS to do something real quick or get a file off of the macOS partition and put it on the external disk or something. Inevitably I’ve got to sit and wait for Winclone to finish. It is also niggling that if I open the menu icon, it has NO IDEA when the next backup is due. Runs all these backups and still says the next run will be AUGUST 26th, perhaps if it kept track better it would know not run a backup EVERY SINGLE TIME IT STARTS.

Fourth issue is that since encrypted external disks don’t unlock for a while after logging in. If I put my backup on the same drive as my Time Machine backup (which is where I’d like it to be) Winclone Incremental Backup then complains about the drive not being available on every boot, just because it wasn’t mounted fast enough. This is incredibly frustrating. See above, it should just wait for the disk to be available.

Now finally, I would be fine with ALL of this if there was a command line interface. I would be more than happy to write myself a bash script to suit my needs for a scheduled but unobtrusive backup and put it into launchd myself, but there is no command line interface that I can tell. I could do all of my own checks – is this on battery, is the drive connected, etc… Then fire it off myself but there doesn’t seem to be a way to do that either.

I have been so annoyed after purchasing Winclone that I’ve really looked into all the other options I can find, it does seem to be the best at what it does. It just seems to be exclusively made for desktop users who have ample internal storage and don’t use Windows all that much.

Most of this could be solved pretty easily by just adding the option to wait for the disk to mount before beginning the backup. I would REALLY like to know why when I’ve scheduled a backup for a later time the damn thing just decides, “OH YOU BOOTED! Let me back everything up! Hold on…” If I wanted it to fire off every single time, I wouldn’t have it scheduled to fire off once a night when I’m not using the computer. This would be ESPECIALLY annoying if I told it to fire off once a month or once a week.

Well I just found out something that may help… Apparently the behavior of trying to backup when the app starts is only when you select “Daily” as your backup schedule. When weekly or monthly are selected. Even if weekly has every day of the week selected it keeps proper track of when it’s supposed to fire off.

If daily is selected it will fire a backup off at every start and not update the time it is supposed to backup next.

Thanks. I’ll do some testing and narrow down what the issue is and get it resolved.