USB stick - MDM created - not recognised using Startup Manager

Hi folks, just getting started with Twocanoes, MDM in particular.
Set out to create my first workflow and saved it to disk image.

My understanding was that this would create a “bootable usb stick” in my case containing Catalina.
FYI I followed the Getting Started with MDS 3 & 4 video as much as possible.

First thing I did was download the necessary installer images. That worked perfectly. I then realized I needed to unpack the installers from dmg format to format, so no big problem there.

Next I ran into a problem Unable to save workflow issue that could be solved by unchecking ** sign packages**.

Now my question:
Suppose I start any mac while pressing Option-key this will make the mac boot into Startup Manager. It seems however that my newly created MDS bootstick does not show up as a boot option??
What am I missing here?

Might this have to do with having “Automatically run workflow … after … seconds?” unticked?

MDS from recovery. Check out this video on the entire process:

starting at minute 20 is where I boot into recovery.