Using WC to install W10 on External USB SSD

I have W10 installed on my internal BC partition in my 2017 iMac. I’ve used WC to create an image on an external drive and in the preferences I have the Block-based imaging unchecked. I have an external SSD in a cage that connects to the Mac with USB-3. I’ve formatted the drive as MS DOS Fat(32) with a GUID partition map.

I’ve restored the BC image to this drive. When I boot my Mac, I can see the USB drive, but it’s only labeled EFI boot. I don’t see anything with the name I gave the partition. When I boot this, it starts to boot and then stops and eventually I get a message that it can’t boot this and then it automatically reboots my Mac.

I have not done sysprep.

Is there something else that I’m missing?

Do you see the files after restore? It looks like you are following the process correctly. We have tested with a limited number of external drives (my Samsung T3 USB-C drive works well), but have not tested with a 2017 iMac. Looks like I might have to go shopping for a new mac this weekend :slight_smile:

What is the external drive you have connected? What message do you get (is it a blue screen with an error code)?


Typically, yes, I can see the files. I’ve tried a number of things, including installing W10 with the SSD inside my old MacPro, which works and which I can see on my older iMac and which boots on my older iMac. It’s when I take it to my 2017 iMac that it fails to be listed as a bootable object when I boot the Mac with the option key held. In that situation I don’t always see it in Mac OS either, but strangely enough Disk Utility will see it.

I’ve tried doing it as an MBR partition and a GPT partition. I’ve tried, within WinClone setting the boot type as legacy and then EFI. I’ve tried restoring the WinClone image to the SSD. If that works, and it doesn’t always depending on what else I have tried before I get to that point, I can see the files inside MacOS when I open the drive. In that situation, when I boot to the boot loader, I’ll see the USB drive, but ONLY the part labeled EFI. I never see the actual Windows partition. If I choose to boot the one labeled EFI, it looks like it’s going to boot, but eventually I get the new WIn10 BSOD with a message that says something like unknown or unmountable boot volume or boot device.

The one thing I haven’t tried is going back thru the old procedure using imagex and pulling out the special boot loaders so that Windows can be installed on an external disk. I figured putting it in my old Mac Pro, internally, would have taken care of all the necessary things and I wouldn’t have to do that. I am wondering, though, with the changes that appear to be in the Sierra and 2017 iMac combo, if even doing the longer more convoluted procedure will allow it to boot from an SSD.

The drive it self is a Crucial SSD; sorry can’t remember the model in an OWC USB-3 drive cage.

Looks like I figured it out; stumbled into it is probably a more accurate statement. I went back and wiped the SSD and configured it as GPT. Then, after more reading, I decided to give WinToUSB a try. I happen to be using an Enterprise copy of Windows so the free version of WinToUSB wouldn’t even try, so I had to upgrade to professional. I assume that a non-Enterprise version of Windows 10 probably would have worked with the free one. WinToUSB is a Windows program, so yo have to have Windows running internally on your Mac.

Anyway, I tried to use WinToUSB to copy my Windows files to the SSD, but it wouldn’t work; apparently because of the GPT formatting. So, while in my internal BC machine, I started up Windows Disk management. I could see on the SSD that there were two partitions. One was an EFI boot partition and the other was the large partition where I would want Windows to be installed. So, I deleted the larger one, leaving the little EFI partition. Then I set up a simple drive on the now uninitialized large partition and let Windows configure it like it wanted. Then I was able to use WinToUSB to “instal” Windows 10 from DVD to the SSD. When it was done, I rebooted the Mac with the option key held.

Initially I was disappointed. At least the boot manger recognized the new disk, but it was NOT labeled Windows or whatever like I am used to seeing. All I had was a partition labeled EFI. In the past when I have seen this, I’ve not been able to boot, but I gave it a shot anyway. To my surprise it booted Windows and everything seems to run OK.

The one downside of this is that I needed to get the BC drivers and, unlike previous versions of BCA, there’s not an option to save off the BC drivers to a USB stick. But, when I had originally installed BC in my internal disk, I discovered that the BCA process creates a D: drive and on the D: drive are all the things it needs to install Windows, including BC drivers. Before allowing the BC driver wizard to run, I copied to my desktop the BootCamp folder as well as the $WinPEDriver$ folder. These are the two folders needed to run the BC driver wizard.

So, now all I had to do was to copy those two folders to my new Windows install on the SSD and run the BC Driver wizard. This worked perfectly. I now have a running Windows 10 desktop on an external SSD.

I did just discover that on the first screen of the new BCA, there is an action menu that allows you to download the BC drivers. Totally missed that my first time thru.