VM Auto Login Takes Two Tries MacOS Mojave

#1

After a reboot the login doesn’t take reverts back to boot runner. When tried again it works.

This is the last piece I need to get working to make VMs a viable option for us. See attached video for example.

Video of Issue occurring

#2

Any ideas on this one? Any more information needed?

#3

It will also get stuck like this indefinitely. Boot Runner 3.1 (29029) MacOS 10.14.3

IMG_0806

#4

I have seen this due to other processes stopping the login window. Do you have any security or anti virus software running?

tim

#5

Nope this is a clean MacOS Mojave install 10.14.3

#6

Tried this again this morning with a completely fresh install of 10.14.3 and I get the same results bonks on the first try works on the second try. If I reboot and have it auto login it gets stuck in a sate with no login at all and just the dunes as the background. Would really love to get this working. let me know if there is anything else I can do.

#7

Any advice on this one? Its been a few weeks and I haven’t been able to get past this error.

#8

We will try and replicate it inhouse. What Mac identifiers have you seen this on?

tim

#9

iMac Retina 4k 21.5in 2017

MacOS Mojave 10.14.3 (Fresh Install no other apps)

Boot Runner 3.1 (29029)

#10

we are investigating with the iMacs in our lab and will report back shortly.

tim

#11

We narrowed down the issue and I have a fix:

At some point, the login window changed. We used command-return to “reset” cursor in the username/password fields, but it now makes the username/password disappear. Pressing again makes it come back and resets the cursor, so we modified Boot Runner to do that.

Let me know if it works for you and we will roll into an update.

tim

#12

Awesome thanks I will test that right now and let you know.

#13

Ok I have installed the new version. It now doesn’t login at all same thing I saw when it wasn’t correctly added to accessibility.

I removed and then re-added to accessibility and rebooted but still no login when clicking the windows icon at least with the same configuration profile from before.

Do I need to rebuild the config profile?

#14

I suspect it is related to accessibility? Are you able to navigate with the arrow keys in boot runner before touching the mouse? If not, then it is related to accessibility. Try deleting all copies of Boot Runner, rebooting, and verifying it disappears from Accessibility. Then install and add it to accessibility and try again.

tim

#15

I have uninstalled and rebooted then reinstalled checked to make sure it was out of accessibility then it came back.

I do have keyboard movement on the Boot Runner screen but still no login.

I even retried downloading my known working configuration profile but still no login just a blinking cursor.

#16

I just replied to you via our support portal. Let me know if you didn’t get it.

tim

#17

I have a completely clean system to work with this morning.

I have installed the new bootruner, ran license and ensured it is in accessibility.

I do have keyboard controls on the boot runner screen, but still no login when clicking the widows button only a blinking cursor.

#18

I sent out a new build. Did that work to resolve the issue?

tim

#19

Sorry this took me so long to get back to you on I was out of the office. Yes in testing now this does work now. Thanks for your help.

1 Like