Web Service won't start

Updated to Monterey 12.2 and Web Service won’t start. Slide switch to ON, then slides off.
Updated to the latest beta and still no fix. Version 4.2 (48065)
Using port 8100, tried changing port, app crashed.
Also, Show Log does nothing in the menu.

Log at ~/Library/com.twocanoes.mds.log

2022-01-31T19:00:22-05:00:munkireport version checking. latest version:5.6.5 installed version:
2022-01-31T19:00:25-05:00:munki version checking. latest version:5.6.2 installed version:
2022-01-31T19:00:56-05:00:Could not connect to the server.
2022-02-01T08:07:31-05:00:munkireport version checking. latest version:5.6.5 installed version:
2022-02-01T08:07:32-05:00:munki version checking. latest version:5.6.3 installed version:
2022-02-01T08:07:33-05:00:Could not connect to the server.

try disabling different services (like munki and munki report) and see if it then starts up. We had an issue with PHP in MDS 4.1 but I thought it was fixed in the current 4.2


Munki and munkireport do the same thing. Click on, immediately turns off. I don’t have those services running anyway… I downgraded to Version 4.1 (41137) but still doing same thing.
This happened after upgrading to Monterey

Are they selected in the web service? If so, try disabling them.


It’s happening on any web service. Munki, munkireport,… getting. “There was an error starting up the web service” probably some apache config files? I dunno. just looking for something to “rm -rf” to hopefully fix!

I am having this problem as well. When I uncheck the munki and munkireport the web services start fine. Again, with web services off if I check only munki they start fine. But with only munkireport checked the web services will not start.

I have checked permissions on the files in the munkireport system and they all seem correct. I don’t know what else to do.

Help :slight_smile: