What's New in SD Clone 3

I purchased sd clone 3 to clone my kodi openelec and Pulse. I followed the directions and successfully created a clone. However Kodi running on my Raspberry Pi3 doesn’t read the card. Openelec is running Lenex but nothing was mentioned about there being any problems with Lenex.
So whats the story. Is it something that has a work around or am I stuck with software I just purchased today with no recourse. I see nothing about refunds.

Don’t worry about getting a refund…if you are not 100% happy, we will refund your purchase.

Can you tell me a bit more about the process you followed and how I can replicate it to find the error? What is the best way to create the SD card in the first place so I can test with SD Clone?


Hey, I downloaded the trial which said it was fully functional, however, I can only select one destination at a time (I’m trying to write 10 images at once: I have microSD card readers hooked up to a USB-3 powered hub, so bandwidth shouldn’t theoretically be a problem). Is the multiple simultaneous connections something that is unlocked with purchase? I want to be sure this will work for my needs before I purchase it.


not sure why you are not getting multiple restores, but just upgrade in the app, and if it doesn’t work, i’ll refund your upgrade/purchase.

Also, be aware that the bottleneck is usually the bus. I got good thouroughput on my MacBook Pro when I had a 4 port reader on 2 different USB ports. Adding a USB-3 hub and increasing to 8 SD Card at once on one bus worked, but wasn’t any faster than doing 4 cards twice on the single bus. Make sense?


Understood about the difference it makes to use different buses. I was thinking that since USB-3 has theoretical 5Gb/s throughput it would be able to handle more cards. I’m using a new MacBook Pro with USB-C (usb3) and a powered USB-3 hub with USB-3 SD adapters.

I’ll try the paid version and let you know what happens. Thanks!

You are correct. I have a 4 slot SD card reader that I use per USB port.


@tperfitt Ok, it didn’t work at all. There appears to be a problem with the purchasing mechanism. I first purchased the standard version, which of course does not allow simultaneous imaging (the whole reason why I need this software), so then I purchased the Pro from the website because it appears as though I have SD Clone Standard but couldn’t find a place to download the Professional, which then sent me a link to download, but when I tried to activate with the Pro activation number, it said wrong version… however I’m trying to download the version from the email I received after purchasing the Pro! So then I thought maybe if I purchase in-app it would work. No luck. So now I’ve paid for 2x Professional licenses and one Standard license and none of them work. Can you please refund all.

I sent you a new license key and we are working to resolve the issue with the registration system. Sorry about that.


SD Clone 3.1.1 beta is now available: https://twocanoes.com/products/mac/sd-clone/history/

  • Reduced prompting for permissions
  • Added support for different compressed image types: .zip, .gz, .xz, .bz, .Z
  • Support for offline licenses
  • Various minor bug fixes

New version released: SD Clone 3.1.1. Update in the app.

New version released: SD Clone 3.1.2. Update in the app.

  • Fixed issue affecting product trials