When changing Legacy Boot to EFI, change not shown

I have a 2012 MacBook Pro 9.1 with a High Sierra APFS partition (SSD drive) with a non BootCamp NTFS partition.

The NTFS partition has a Winclone Windows 10 (64 Bit) image cloned onto it. The Windows OS started of as a Windows 7 (32 Bit) version on a MacBook 4.1, then upgraded to Windows 10 via the Microsoft upgrade facility when I purchased the MacBook Pro 9.1. The NTFS partition has been erased and then re-partitioned and Win 10 re-cloned onto it using Winclone 6.

The Win 10 partition boots without problem but why does the Mac Disk Utility say it’s non bootable and the Application Paragon NTFS 15, I use, always see the Win 10 as a legacy boot partition regardless of how the Winclone booting option is set. Could this be that the original clone was made from the Windows 7 OS.
Why when I use Winclone to change the Legacy boot to EFI is there nothing that indicates that the process was successful, I only see a message to say “copying files…”, there is no indication that the Win 10 is now an EFI boot partition or Legacy.

This is an addition to the above.

I tried an experiment with changing the Legacy Boot to EFI and this is what happened.
Now remember Win 10 was booting and working OK as Legacy boot from pressed option key start.
Went into Winclone 6 and selected change to EFI and was informed that the files were being copied. No other notification.
Restarted MacBook with option key pressed.
The only difference seen was that a new icon “Windows” had been added to the bootable partitions on the screen, the original EFI bootable partition was still there.
Selected “Windows” for the boot drive and all that happened was a black screen with a few words on it and a blinking cursor.
Turned Mac off by pressing power key until it shut down
Re-started with option key pressed and then selected the original EFI icon and all that happened was a blue screen suggesting that the Windows partition needed repair
So now neither Windows boot option worked.
To get the system back working did the following.
Turned Mac off by pressing power key until it shut down
Restarted in recovery
Erased full SSD drive ( 2partitions), not a straight forward operation
Re-formatted to APFS
Re-started into a backup cloned High Sierra OS partition on another drive
Cloned Mac High Sierra back onto SSD with Carbon Copy Cloner
Shut down Mac
Restarted MacBook with option key pressed.
Booted into new SSD High Sierra partition
Added NTFS partition
Re-cloned Windows 10 back onto NTFS partition with Winclone 6
Now back to full 2 OS MacBook Pro!
Will not try changing to EFI now its been proved to cause a BIG problem with the present setup

Still don’t understand what’s happening but at least I know how to sort things out if things go wrong!
Thank goodness for complete cloned back ups.

Can you explain a bit more about where Mac Disk Utility shows that it is non-bootable?


I have attached 3 pics to help

From Diskutil

From Terminal


From Paragon NTFS

Hi sorry I realised I also had these 2 pics of the Option start screen.