Winclone 4 Migration Shrink non-functional


#1

My old MacBook died, but I salvaged the hard drive. I want to migrate to my new 2017 MacBook pro with Mojave. To date, nothing on WinClone has functioned. To start with, I only have 500 GB Hardrive (I used to have 1 TB). Shrinking the file system reduced the drive from 128 GB Space and 300 GB partition to 128 GB and 300 GB (nothing changed). I don’t have 300 GB to spare for windows. If we manage this problem, we’ll move on to the iso file required to make the partition, which I don’t have.

Thank you!


#2

If you salvaged the hard drive, you can shrink the windows partition prior to migrating it and should be able to make a Winclone image that will restore to a partition at least the size of the used space. Make sure to have a good backup and a Winclone image of it prior to shrinking just in case of errors.

tim


#3

Yes, I used the shrink function in Winclone. It whirred around for about 15 minutes and said it was finished. When the windows partition reappeared in winclone, its partition size was unchanged.


#4

then I tried expanding the partition, which I know is counter intuitive. That worked just fine. Then I re-shrunk it. The partition remains 300 gb. sigh


#5

The shrink function does not change the size of the partition but rather changes the size of the filesystem. You have to restore the shrunken filesystem to a smaller partition to see a size change.

tim