Winclone 6.1.7 restore stuck at "Updating Legacy"

I am trying to restore a bootcamp volume of Windows 10 on a 2017 MacBook Pro to an external SSD. Every time I try to do the restore, it gets about 90% done on the progress bar and then it stalls at “updating legacy”. I let it run all night and it never finishes.

I tried restoring to a different external SSD and same problem. I tried restoring to an image first and then from the image to the SSD, same thing. I tried block-based imaging, same problem.

Same problem under Winclone 6.1.6. I am running the latest version of macOS High Sierra. I am able to boot into the bootcamp partition just fine and I have run chkdsk on the bootcamp drive and found no problems.

What should I try next?

The “updating legacy” means that it is completed restoring, but something is causing an issue. Check the log and also try force quitting and then setting legacy manually:

tim

Hi tperfitt, I’m (still) seeing this today on WinClone 7.3.4.

In Preferences, I have “When restoring, update BCD” set to “Ask”, and I’m restoring a small (64GB) WIn10Pro partition to an external SSD, formatted as GPT, using a 2012 MacBook Pro i7 (not Retina). (I don’t want WinClone modifying the BCD because this SSD dual boots between two Win10Pro installs.) So it really shouldn’t be trying to update the Legacy boot sector ANYHOW, without asking me, right?

Here’s what I caught in the logs:

default 11:19:34.977171 -0400 com.twocanoes.WincloneHelper Executing “mkntfs --sectors-per-track 63 --heads 255 --partition-start 723181568 --quick -L WIN10-[REDACTED] /dev/disk2s4”
default 11:19:36.982621 -0400 com.twocanoes.WincloneHelper Executing “wimapply /Volumes/[REDACTED].winclone/Windows.wim 1 /dev/disk2s4 --strict-acls --check”
default 11:20:13.078739 -0400 Winclone 27366555: RECEIVED OUT-OF-SEQUENCE NOTIFICATION: 169 vs 240, 512,
default 11:27:50.356518 -0400 powerd Process Winclone.1252 Summary PreventUserIdleSystemSleep “Restoring Winclone Image” age:00:08:19 id:4295002885 [System: PrevIdle DeclUser kDisp]
default 11:28:40.761083 -0400 com.twocanoes.WincloneHelper Unmounting disk /dev/disk2s4
default 11:28:52.221947 -0400 com.twocanoes.WincloneHelper Setting up legacy booting to /Volumes/WIN10-[REDACTED]
default 11:28:52.222546 -0400 com.twocanoes.WincloneHelper *** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘*** -[__NSPlaceholderArray initWithObjects:count:]: attempt to insert nil object from objects[2]’
*** First throw call stack:
(
0 CoreFoundation 0x00007fff3292c439 __exceptionPreprocess + 256
1 libobjc.A.dylib 0x00007fff5d0c43c6 objc_exception_throw + 48
2 CoreFoundation 0x00007fff3296b9f0 -[CFPrefsConfigurationFileSource initWithConfigurationPropertyList:containingPreferences:] + 0
3 CoreFoundation 0x00007fff3283ef45 -[__NSPlaceholderArray initWithObjects:count:] + 230
4 CoreFoundation 0x00007fff328ab692 +[NSArray arrayWithObjects:count:] + 52
5 com.twocanoes.WincloneHelper 0x000000010b1fdf68 com.twocanoes.WincloneHelper + 98152
6 com.twocanoes.WincloneHelper 0x000000010b1eca85 com.twocanoes.WincloneHelper + 27269
7 com.twocanoes.WincloneHelper 0x000000010b1f6961 com.tw<…>
default 11:28:52.595574 -0400 ReportCrash Saved crash report for com.twocanoes.WincloneHelper[1453] version 7.3.3 (40001) to com.twocanoes.WincloneHelper_2019-09-22-112852_Jedi.crash

(I redacted out the partition info because it is named with some sensitive info, but no weird characters or anything.)

If I just cancel the clone, it looks like the partition is left intact; I’m not sure what normally would come after this stage, so I don’t know what I’m missing… but I haven’t tried booting to it yet.

I’m downloading the WinClone 8 beta and see if I can produce for you there, too. And, from what I gather, there’s clearer logging, so maybe I’ll catch something more. Will update…

Yes, still does it under the same circumstances in WinClone 8 beta. (The current download of the beta is expired, but interestingly allowed me ONE launch, it stayed running after I hit the Visit button in the expiration dialog… each launch thereafter it won’t stay running. But I was able to do one restore.) I have the log saved, if you’re interested. (Is there a way to Direct Message them?)

sure, just send it to support@twocanoes.com or in the twocanoes-winclone slack channel on #macadmins.

tim