Winclone 6 issues


#1

I had an issue updating Windows 10 about a month ago. Part way through, it froze and Windows became unbootable. I figured, big deal, I’ll just restore my backup.

Winclone 6.0.3 wouldn’t do it. Kept throwing out some odd message (didn’t save a screen shot) about not being able to restore to the partition. I tried reformatting the partition as MS-DOS (FAT32) as I’ve done numerous times in the past to either erase an existing partition I was using for my Windows install, or simply creating a new partition on another drive. This had always worked in the past, but now it wouldn’t.

Today, I had time to try and tackle the issue again and got out my Win 7 Home Premium DVD and booted to that so I could use Windows itself to quick erase the partition as NTFS to try and get past this error.

After that short step, I launched Winclone and was told there was an update to 6.0.4. Part of which included a fix for restore errors. So I did that. Started the restore again, and yay!, it actually started restoring my backup.

Bad news. This is not a large partition (100GB) and the Windows image is pretty much just Windows 10 with the Acrobat Reader and few other small apps added to it. In other words, not much data to restore.

In the past, the entire restore typically only took about 25 minutes. This restore has been going for almost 5 hours now, and it still isn’t done! It is going, but at the pace of a snail trying to go up a mountain coated with Teflon.

What’s going on?


#2

Can you send the logs from within the app and I’ll take a look at them:

tim


#3

Hello Tim,

I’ve sent a support request through Winclone 6, and clicked the box to include the logs. You may notice an aborted restore, besides the one that was taking forever. To explain:

When the restore finally finished, I checked the drive, and it hadn’t taken on the name of the Windows image, as it normally does. Instead of “Windows 10” as the drive name, it stayed at “Untitled”. The files were there and it was NTFS, so I tried booting to the drive.

That didn’t work. Got a DOS message that the drive was not bootable and to insert a disk in a floppy drive to try again.

Thinking the failed Win 10 updates may have really screwed up the drive, I repartitioned it entirely. And yes, something had been goosed. Trying to remove the top-most HFS+ partition would keep generating an error in Disk Utility that the action couldn’t be performed.

So, with backups of all three partitions on hand, I erased all of the partitions, which then allowed me to do a full wipe and apply a single partition to the entire drive. That forces Disk Utility to write an entirely new EFI table. Then I put it back the way the drive was (three partitions) and restored the two Mac partitions.

Then I tried Winclone again. As before, it was restoring extremely slowly, so I stopped it about 5 minutes in. That’s what the last log entries will be, showing the aborted restore. The restore before that is the one that did finally finish, but didn’t produce a bootable partition.


#4

Thanks for sending the logs. I replied directly to you but here is what I said:

It looks like the clone is getting to “6.00 percent completed” and hanging on some issue with the disk. It is doing a file based restore and we have seen this if there are some corrupt files. I would recommend setting the preferences to do block-based imaging, and create the image again. Then restore and see if the problem is resolved.

tim


#5

Yes, saw the email. I’ve been responding here so others can see the conversation. If we find a solution, it could help others with the same question.

Unfortunately, the Win 10 install is gone. The first attempt to restore the backup took care of that avenue, so I have no Windows volume to try block-based imaging with.

If I can’t get this backup restored, my only option will be to install Windows 10 from scratch. And I’ll likely have to go the very long way around of installing Win 7, then Win 10 over that.

This particularly bites because I wanted to get the new Win 10 installer for users who did the free upgrade. With that one, you don’t have to enter a product key to get it to install since Microsoft’s servers will recognize the hardware has already been licensed and activated. Supposedly, you can only get that installer while in Windows, and I have no other computer with Windows on it.

I can get the Win 10 installer through the Mac OS, but only as an .iso file. I would prefer the installer that allows it to be put on a flash drive. Maybe I can do that with the .iso image. Haven’t checked that yet.


#6

Can you check the size of the image that you created? Do you have any idea of the used space of the original partition?

tim


#7

The size of the image I’m trying to restore is 11.7 GB. It restores to about 28 GB of data on 100 GB partition.

I started the long way around and installed Win 7 Home Premium, 64 bit, from the original DVD, then applied the Apple Boot Camp drivers for my Mac. I then saved a new Winclone image of that before proceeding any further.

With that Win 7 image set aside, I was then able to use Win 7 as a way to get the new Win 10 installer created on a flash drive. Yay! Now I can always reinstall Win 10 from scratch on a bare partition and it will automatically be activated.

So, I booted to the Win 10 flash drive and did a quick erase of the Win 7 partition as NTFS. Only now, Microsoft’s idiot installer says I can’t install Win 10 because the drive is GUID, and it’s required to be GPT. Well, someone needs to inform MS’s moronic programmers that GPT stands for GUID Partition Table. But I’ve gotten around that before by repartitioning the drive as MBR, then back to GUID. That didn’t work this time. Now the Win 10 installer insists the drive’s partition table is MBR, when it clearly is not.

Fine. To heck with that. I booted back into El Capitan and decided to restore the Win 7 image I just made, and then upgrade it to Win 10 while booted to Win 7.

Big problem. I’ve been waiting for 15 minutes now, and Winclone 6.0.4 hasn’t budged one iota restoring the Win 7 image.

I have never, ever had any issues like this using Winclone 5.x or older. I can only assume from these repeated failures that Winclone 6 has serious problems. I’m going to have to reinstall Win 7 from scratch and put Winclone 5 back on my Mac to create another new image. I at least know version 5 will work to do a restore.


#8

Sorry you are having issues. Can you verify that you had it set to block based mode in the preferences? If so, then Winclone should behave the same as in Winclone 5 in terms of the image created.

tim


#9

Heh! Perfect timing on your response, Tim. I was just getting to the end of some testing.

After much monkeying around, I finally got Win 10 back on my drive. I then cleared up much of the extremely wasted space Windows uses by default. 12 GB opened up by using its built in drive cleaning tool and removing the old Windows 7 data, among other junk. Turned off hibernation which opened up another huge area of the drive. Lastly, changed Windows’ gross overuse of disk space by changing the page file from 32 GB to 2. There’s no need for 32 GB of wasted drive space with 16 GB of RAM installed. Especially for the little need or use I have for Windows in general.

After all that, the entire Windows partition is only using 12 GB out of 100.

I don’t recall Winclone 6 even having a block based feature at first. But to be sure I was using a version 6 copy that was clean (not corrupt in some way), I downloaded and installed it fresh. It turns out, that was possibly an issue. I used both 5 and 6 to create backups of Win 10. Both images came out to 9.39 GB. Unlike before, Winclone 6 created the image much faster. Which is what makes me think there may have been something wrong with the copy I was using.

Another thing that maybe points to a damaged Winclone 6 copy is I still had that install on the drive when I imaged Win 7. Even though block based copying was on for Winclone 6, the two images did not come out the same, as they did for Win 10. The Winclone 5 image is 24.21 GB, and the Winclone 6 image is 14.94 GB. Something sure seems wrong between those two.

That’s all the further I’ve gotten. I now have backups of the initial Win 7 install created with both Winclone 5 and 6, and Win 10 images created with both. The only thing left to test is restoring. And after all the hair pulling just to get WIn 10 back on my Mac and working, I don’t have the will at the moment to try it.


#10

Finally had the time and nerve to restore Windows 10 with Winclone 6. Since I had a backup of the partition using both Winclone 5 & 6, if anything went wrong using version 6, I could always use the known, working version 5.

Winclone 6 quickly and correctly restored the backup, which booted normally.

So, it appears something was indeed wrong with the copy of Winclone 6 being used earlier. What was wrong with it? Who knows. Could have been updated incorrectly through Sparkle when Winclone notes a new update is available. Reinstalling 6.0.4 fresh from your download page rather than relying on updating an older version worked. But then, updating an older version may also work just as well. No telling when or how what was on the drive got corrupted.


#11

Thanks for letting me know. Glad that it got resolved, and it is indeed strange that the update was somehow corrupted. I’ll keep an eye out for others that may have similar issues.

tim


#12

windows 10 is compatible with high end systems with greater processor ram and GPU, maybe your existing system is not compatible with it,thats why you are facing problem.