Winclone 6 on IMacPro5K for sure not working

so, after 2 completely lost, wasted and annoying weekends and more evenings I can say for sure that Winclone is not working with the new IMacPro.
Up to now I have reinstalled everything from scratch, following every available hint several times.
The results are:
Out of the box (new IMacPro 5K) it s impossible to run Bootcamp assistant without getting stuck at the “unable partition” .
Booting into recovery-partition and erasing all the internal partitions, creating a new HFS+ partition , then starting the HighSierra Installer raises an error …. unable to install this type of computer on HFS …use only APFS.
Back to creating the partition …this time by selecting APFS (without encryption) …the installer starts…but as soon as osx is absolutely fresh and clean and ready …the partition is …apfs(encrypted).
…seemes to be the origin in the new T2 hardwarenecryption as described in the very informative news-article here.

Bootcamp now works and installs w10pro (from ISO)…but after a restart the installer gets stuck by noticing …that some unattended script would be missing ???

Recover now the real W10-image by winclone (newest version) ….inaccessible boot device !!

… Now booting the ImacPro from an external USB-Stick with my cloned backup on it, starting the diskmanager …try to erase the macintoshHD …only APFS as options available.
Going to “partition”…here i can select “HFS+” ….well done.

Now reverting /cloning back my USB-backup to that partition….reboot….worked.

Now I have a working, full installed OSX10.13.2 on HFS+

running bottcampassistant…. now everythings fine…windows10pro will be installed completely.

after several attempts i can state, that w10 and osx are both bootable and working.
but that is a blank w10 without my programms……

before going any further … i`m now creating an image of that fresh w10-bootcamp with winclone.

now running winclone again and recovering my image (from a macbookpro 2014) over that already created and running bootcamp-partition……… reboot——inaccessible bootdevice !!
again…winclone …restoring the just made image of the fresh clean w10 back to the bootcamp partition….
….surprise …that one is working again !!!

So this should be the best proof that the problem of the inaccessible-bootdevice is in the image created by winclone.
winclone image from old computer (3 different ones) ….not working
winclone from fresh installed w10…working.

So, now …what can we do !!??

buying such an expensive 5K+ mac wasn’t my intention in getting such extremely bad experiences.
winclone for the moment does not work at all with apfs…. and after hours of carefully following a complicated path around could only work with hfs+ but even then fails ….

is there any idea or timeschedule when and how this can be fixed ?

btw….by that procedure i lost my recovery-partition……and now i can only reinstall by an extra to be installed usb-device-installer…… i hope i will not have to do so in the near future….

can anyone help ?

well , the final prove is made.
I resetted the iMac Pro completely to factory default (Internet recovery). but left the working bootcamppartition as it is.
status : 1 APFS Partition , 1 Bootcamp partition (both with clean os (OSX HighSierra and Win10pro).

Before doing anything else (not even connected it to a network… i now recovered (Winclone 6.2) the windows image from another /older computer to this one… reboot…inaccessible boot device !!!

again… recover the image made from win 10 (created on this iMac Pro) … working !!!

So this is the clear evidence that Winclone 6.2 migration cannot work with at least the current IMacPro ! … and possibly all of the upcoming new Macs.

As Tim Perfitt describes in his brilliant article, it seems to be the new encryption done by the T2 chip.
Everything created on the same machine , can be imaged and recovered by Winclone…because the encryption (even if nothing in the filesystem is set to do so…windows definitely behaves the same with the coexisting HFS+ and/or APFS (with or without encryption), validates it.

If it is coming from another machine (migrating) the validation will fail (some certificates probably) and you are getting the …inaccessible boot device error.

My conclusiona now are after 10 wasted horrible days :
-Winclone is only usable for backups from /to the same machine , but NOT FOR MIGRATION (standard version therefor is useless)
-Apple is no longer “the good guys”… they seem to grasp onto our property to dictate what and how long we have to buy and obey (same as the “unintentionally” battery slowdown on iPhones.
-I have learned a lot , and will make my next purchase in hard and software very much more careful (apple listen : for this amount of money there are as well machines from HP Z6/8 on the market !)

is there anyone a twocanoe who can honestly tell my how he/she made a proper working migration of a w10 installation from an older Mac to a new IMacPro !?

I’ve lost too much time now and have to reinstall/reactivate licenses for everything … no, user experience is something different… I should ask for a refund…

When I did the iMac Pro testing, I had a Windows 10 image and successfully restored it on a Boot Camp partition on the iMac Pro. You may need to run sysprep on the image prior to migration, as the iMac Pro has very different hardware.


Well, where did you create the win10 originally? On the same machine (imacpro) or another older mac?

As i mentioned…images from the same imac are working, but not those created on another machine without t2…regardless it is hfs+ or apfs, osx10.11/10.12 or 10.13.

And yes,as in my original post…the imac has a total different hardware/controller…but what should sysprep heal on the original mac? At this time it cannot know on which hardware it will be restored…from where should it get the appropriate drivers?

In fact, i tried to install before imaging a 3rd time every driver from the bootcamp 6.2 package (thanks to a hint from vern)… everything worked except the most critical intel storage controller… all that did not help.

So what could sysprep do?

It is a wellknown tool for correcting systemsettings, not for installing future needed drivers… or am i wrong?

How did you manage to “inject” the drivers for the imacpro’s new hardware into the original w10 installation, so that windows can automatically access it during bootup?

At this stage you have no option to manually run or point to a necessary driver (f.e the storagecontroller).

Am 08.02.18, 22:15, Tperfitt schrieb:

The image was one that was taken from a 2016 MacBook Pro. I didn’t have to inject any drivers.