WinClone 7.1.1 + Windows 10 image to restore = black screen with "Error loading operating system_"


#1

WinClone 7.1.1 + Windows 10 image to restore = black screen with “Error loading operating system_”.

Changing my iMac internal hard drive, I want to get back a saved Windows 10 BOOTCAMP partition made using an upgrade purchase of WinClone 7.1.1. My Desktop Computer is running latest MacOS 10.13.6 version.

Unfortunately, when booting the BOOTCAMP partition, I get a black screen with an error message “Error loading operating system” followed by a blinking underline cursor.

Trying EFI Bootable or Legacy Bootable has no effect.

I’m also unable to use “Bootcamp Assistant” to install Win10_1803_x64.iso has this Apple Software don’t recognize ISO files.

So I am stuck.

Any ideas?
Thanx.


#2

I would try disabling SIP and try restoring again. See this link for how to disable SIP:

tim


#3

Hi,

I’ve try “disabling SIP” and then restore again.
Still the same behaviour “Error loading operating system_”.

Still stuck.
Any ideas?
Thanx.


#4

The “error loading operating system” means that it is booting into legacy mode but could not find either the Volume Boot Record. What happens when you switch it to EFI mode?

tim


#5

I just choose EFI, try to boot: unsuccessful. Than choose Legacy. I suppose it say’s OK. Retry to boot: unsuccessful again.

I’ve also try to restore from an old backup (2018, March) of my BOOTCAMP partition made with Winclone 6, using Winclone 6 on another Mac running El Capitan (with SIP deactivated). Give me same error.

It seem that my Mac starts booting BOOTCAMP partition but Windows 10 operating system is corrupted (hard to believe because I use 2 different backups made with 2 different versions of Winclone: 6 and 7).

So no solution to solve my problem.

By the end on week, I will try making an USB Windows boot on a PC running Windows 10. And than restore BOOTCAMP backup made from Windows 10 from a external drive.

Cheers,
jlatx


#6

Hi,

I was not able to restore my Win10 backup using USB boot Win10 Tools. It say’s that my saved Win10 is a BIOS one and that target BOOTCAMP partition is UEFI, so it’s not compatible.

I set back my BOOTCAMP Winclone restore EFI Bootable. Windows starts but I get a INACCESSIBLE_BOOT_DEVICE blue screen.

Then I try to use bcdboot DOS commands under USB boot Win10 Tools. Unsuccessfully.

I think the problem is that my Win10 Winclone backup is a BIOS one and I’m not able to change it to UEFI. I’m also unable to format my HD in MBR way and use partitions greater than 2Tb (previous HD partitioning was OK with MBR and a partition 5Tb sized, but maybe it was an Hybrid MBR…). I’m quite lost!

Thanks to help me.
jlatx

PS: Disk Scheme

diskutil list

/dev/disk1 (internal, physical):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *10.0 TB disk1
1: EFI EFI 209.7 MB disk1s1
2: Apple_HFS tanker10Tb 9.9 TB disk1s2
3: Microsoft Basic Data BOOTCAMP 99.8 GB disk1s3

gpt -r -vv show disk1

gpt show: disk1: mediasize=10000831348736; sectorsize=512; blocks=19532873728
gpt show: disk1: PMBR at sector 0
gpt show: disk1: Pri GPT at sector 1
gpt show: disk1: Sec GPT at sector 19532873727
start size index contents
0 1 PMBR
1 1 Pri GPT header
2 32 Pri GPT table
34 6
40 409600 1 GPT part - *** unique id ***
409640 19337282848 2 GPT part - *** unique id ***
19337692488 262840
19337955328 194916352 3 GPT part - *** unique id ***
19532871680 2015
19532873695 32 Sec GPT table
19532873727 1 Sec GPT header


#7

Try the latest beta and set the boot camp partition as EFI bootable and see if it resolves the issue.

tim


#8

Hi tperfitt,

I found a way to solve my issue.

First, I have an old mid-2010 iMac. So the only way to get BOOTCAMP running is to use MBR mechanism. MBR can only address 4 partitions in 2.2Tb of disk space.

Notice that Windows 7 and 8 can only boot on MBR disks. Windows 10 can use MBR as well as GUID disks (EFI = GUID). But if you have a Windows 10 MBR Winclone backup, you can’t restore it on a GUID disk, as some boot files may be missing (I guess symmetrically GUID can’t be restored on MBR disk).

Second, I have a large hard disk 10Tb and I want to use all the size (otherwise I will loose 10Tb - 2.2Tb = 7.8Tb of space, sounds bad). So GUID partition scheme must be also set for this disk. Hopefully, there is a way to get both systems alive (MBR & GUID) and this trick was made by Apple as a “hybrid” MBR.

So my BOOTCAMP partition must be in the first 2.2Tb of HD and one of the 4 1st partitions (MBR limits).

The only way to do this, is to have BOOTCAMP in 1st place. In fact it’s gone be the 2nd, due to Apple’s small EFI mandatory partition made to access the full 10Tb of the disk (see next Terminal.app command):

# diskutil list

view-1

To get this Hybrid MBR/GUID disk, enter the following Terminal.app command:

# sudo diskutil partitionDisk disk1 2 GPTFormat “MS-DOS FAT32” “BOOTCAMP” 96Gb JHFS+ “tanker10Tb” R

*** Warning ***

Above command will erase the whole content of your hard disk (no return back) and create 2 partitions. Be careful to give the right disk number shown by diskutil list command. Mine was disk1. But it can differ depending on your disks configuration.

  • BOOTCAMP will be the 1st partition defined as FAT32 and sized 96Gb.
  • tanker10Tb will be the 2nd one defined as a Journalised HFS+ that takes the rest [R] of the disk.

Then I restored my Winclone backup to BOOTCAMP partition.

But one more thing have to set in order to get Windows running. BOOTCAMP partition has to be “ACTIVE”. This is made using Windows Tools USB key (download here).

Reboot your computer and press [ALT] key to choose Windows Tools USB key (named EFI boot).

On 1st screen, choose [Next]:
view-2

2nd screen, choose “Troubleshoot” option:
view-3

And launch “Command Prompt”:
view-4

A window opens where you can enter DOS command [X:\>] (sorry, french version):
view-5

Enter following command:

> DISKPART

List your volume:

> LIST VOLUME

view-6

Choose your BOOTCAMP partition:

> SELECT VOLUME 1

view-7

Make it active:

> ACTIVE

view-8

Verify that and asterisk is beside your BOOTCAMP partition and exit:

> LIST VOLUME

view-9

> EXIT

Shutdown and boot your computer holding [ALT] key in order to choose BOOTCAMP.
It should run smoothly!

Hope this tutorial will help other people.
Cheers,
jlatx


#10

Hi jlatx!

I joined this forum just because I stumbled across your fix. I’m havign the same problem and am going to try your steps to correct the issue. However I had a question regarding your restore.

After you created you partition scheme, did you boot to an external drive to restore your WinClone image? Or did you restore your MacOS side first and then restore from there?

During the restore, did you write the MBR through WinClone?

I just did some upgrades at the house and moved my old machine over to my wife’s office and am in the process of backing up my MacOS side from the old machine. I plan on using your guide to partition the drive before I restore the MacOS side to the second partition. I wanted clarification on whether I should restore the WinClone backup first or I can restore the MacOS side then once booted there, restore the WinClone backup to the first partition set for BOOTCAMP.

Any help you can offer would be awesome. I don’t know why I didn’t see your post sooner. I’ve been searching the web for the better part of a year for a fix and it sounds like you hit the same exact problem I’m having.

[EDIT] So, just in case someone had the same issue as me and stumbles across this, jlatx’s solution worked almost perfectly.

After partitioning the drive, I booted to a macOS utility drive I have with various tools. I restored my macOS side first. Afterwards I ran DiskWarrior to clean up the directory and then booted to my macOS side. Afterwards, I used WinClone to restore my Windows side and then used a Windows 10 recovery / install USB key to activate the partition. Afterwards I was able to select Windows in the EFI bootpicker and booted normally.

The only problem I’ve run into is in Startup Disk. I now show a Disk2 with Windows and Bootcamp. In the bootpicker I only see the one drive for Windows. It’s a minor issue, that I haven’t been able to find a fix for, but otherwise everything is back up and running normally.

I really want to tank jlatx for posting his fix as it helped me with an issue that had been gnawing at me for over a year. I also want to acknowledge the thought and effort, as I’m sure we are all too aware of forum posts stating “I fixed it” rather than the breakdown of the fix itself.

Cheers!


#11

Hi plastic9mm,

I made everything on a 2nd internal hard disk drive of my iMac as you can see down below:

$ diskutil list
/dev/disk2 (internal, physical):
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *10.0 TB disk2
1: EFI EFI 209.7 MB disk2s1
2: Microsoft Basic Data BOOTCAMP 96.0 GB disk2s2
3: Apple_HFS Macintosh_HD 9.9 TB disk2s3

During Window restore with Winclone, I used “Make Legacy Bootable…” as my old computer (mid-2010) is not able to boot Windows via EFI. This option has write MBR on disk2s0. disk2s1 (holding EFI), was previousely created by “Disk Utility.app” with 2 partitions in order to have full access on disk2s3, otherwise reading MBR record, only 1.9Tb should have been addressable (loosing 8Tb space).

From there, you can choose installing MacOS X on disk2s3 (Macintosh_HD partition) or like I did, use another disk drive (for me disk1) to host this OS.

Hope, this will help solving your problem,
Cheers, jlatx


#12

Try booting with efi or legacy boot so, bootcamp assistant has this apple software don’t recognize iso file.