Winclone 7 restore misreads image size

When I try to restore images created with Winclone 7 (or Winclone 6) using Winclone 7 I get a ‘size issue’ message e.g.:
The image you are trying to restore recommends a minimum volume size of 50.0 GB, but you are trying to restore to a volume that has a size of 67.7 GB. Continue?

The Image was created from a 50 GB Bootcamp partition and I never had this issue when using Winclone 6.

If I go ahead with the restore it seems to work although (and these may be nothing to do with Winclone 7 specifically, I might just not have noticed before) 1) if I boot into Windows and then bring up the Bootcamp console there are 2 Windows startup disks listed disk1 Windows and Windows 2) if I request a Mac OS restart from Windows it fails to recognise the OS and I have to hit the alt key when booting to be able to get back into Mojave and 3) if I run ‘verify’ from within NTFS for Mac it finds zillions of 0x80 errors and corrects them. I haven’t let this process complete as it looks as if it will take hours/days and then it’s not possible to boot into Windows and I have to restore it. If I run disk check when booted into Windows it finds no errors.

The WIM format gives a “suggested” size and we are now comparing it to the size of the partition. It is just a warning and if it worked find in the past, you can safely click Continue. If it runs out of space, you’ll get an error near the end of the restore.