Winclone 7 stalls forever trying to restore Bootcamp Win 10 image to G-tech GDRIVE Mobile SSD

It seems like this is happening to others but I didn’t see my drive mentioned so I thought I’d make a post.

Attempting to restore a Win 10 Bootcamp image made in WIM mode via macOS 10.14.1 and Winclone 7.3. It keeps getting to about 1/8th through the task bar and stalls on Extracting file data. The bytes written in Activity viewer for wimapply stays static and never grows after it halts. It only copies about 15-20 out of 210GB Bootcamp backup each time and then just sits for 10-20 hours and then I give up. It brings the functionality of my computer down when this is happening so I have to force quit it or force reboot if that doesn’t work to get back up and running.

What is going on with this? I’ve tried the Use Block-Based imaging thing but it just either outright failed or only created a 600k file in about 3 seconds and that won’t do anything when attempting to create or restore said image. I’ve tried drive to drive copy from 3TB fusion drive (Bootcamp working and tested in macOS 10.14.1) to 1TB G-Technology Mobile SSD via TB2 and no dice every time. Says Error similar to other posts saying the same thing. This is getting really tedious and the price of the software was no joke either. Please advise. Thanks in advance.

I gave up on this last attempt after 39 hours… Just a bunch of these messages in the console:

Process Winclone.1448 Summary PreventUserIdleSystemSleep “Restoring Winclone Image” age:39:16:01 id:4295000986 [System: PrevIdle]

When it fails in both block based and file based, I would look at both the source and destination. Run CHKDSK /b in Windows to make sure there aren’t any errors, and also try saving the image to a different location.