Winclone 8.0.1 is failing for me

I have a MacBook Pro 15 TB later 2016 with an internal SSD 512GB.
I made a 85GB BootCamp partition and installed Windows 10, which is updated to the latest version. It runs fine and is verified by CHKDSK as OK.
The rest of the SSD drive, I portioned as APFS and installed MOJAVE, and it is updated to latest version. This partition is also checked by DiskUtility as is fine.

Recently the keyboard started to fail and this MacBook has a repair program for the keyboard. Unfortunately it takes a while to get it fixed, because I don’t live in USA. Here where I live, Apple products have a slower time to fix. I use it as my main working device as a database developer and all my work is on that.

Because of that, I bought a external SSD thunderbolt 3.1 case and a Sabrent 2TB NVMe M.2 SSD to back my internal SSD.

To backup the MacOS partition, I used Carbon Coppy Cloner and it was a piece of cake and I had no problem what so ever. I copied it to a 1.3TB partition.

To backup the Win10 partition, I bought Winclone 8.0.1, because I saw many people talking about it be the right tool to migrate a BootCamp to an external drive.

At first I thought it would be a simple copy SSD to SSD like I did with Carbon Copy Cloner but I want to expand the portition from 85GB to 700GB, I saw it was necessary to copy as an image and then restore the image to the new partition.

I did that, I created an image from my BootCamp and it was fine and an easy processes. Later I restored the image to the new partition and it was easy too.

Unfortunately when I boot it, the Windows logo appears and after 10-11 seconds the machine boots again and I have to press the option to select the drive again, after that a blue screen says my drive has a problem number 0X 0000001, (I don’t know many zeros it has). On the Sabrent site there is no mention of a driver to use their SSDs.

I tried the SysPrep but it also presents a error message and doesn’t let make the preparation.

I saw other users had similar problem but the users have to fix it alone. If it is a recurrent problem, Winclone should have a way to fix it to users. Users buy utilities to fix their problems and not let them die half way to the beach.

I also tried to use Carbon Copy Cloner to clone BootCamp, but the partition is 40,3GB and when it clones it, it finds more than 46GB and at the end it doesn’t finishes and gives and error.

What should I do? Create a new BootCamp in the new SSD? On this Win10 I just have Windows 10, Office and Steam launch.

Sorry I did not respond to this sooner. Did you get it resolved?