Winclone 9 stuck 90% through restore

Using Winclone 9 to restore a November image of Win10, total size just under 500 GB.
Machine is a 15-inch 2019 MacBook Pro.
Winclone backup disk is a Samsung T5 external SSD connected with USB-C
It works OK until it’s about 90% done according to the progress bar, then hangs there with no further progress after several hours. I can now see the BOOTCAMP partition in Finder and everything seems to be there (BOOTCAMP is not visible in Finder during the early stages of the restore).

The last few lines from the log you get with Cmd + L are:

2021-01-19T17:03:25+08:00:Extracting file data: 466 GiB of 466 GiB (99%) done
2021-01-19T17:03:26+08:00:Last message repeated 188 times
2021-01-19T17:03:26+08:00:Extracting file data, 89.189995% complete
2021-01-19T17:03:26+08:00:Last message repeated 51 times
2021-01-19T17:03:26+08:00:Extracting file data: 466 GiB of 466 GiB (100%) done
2021-01-19T17:03:26+08:00:Last message repeated 17 times
2021-01-19T17:03:26+08:00:Extracting file data, 90.000000% complete
2021-01-19T17:03:55+08:00:Done applying WIM image.
2021-01-19T17:03:55+08:00:Extracting file data, 90.000000% complete
2021-01-19T17:03:58+08:00:Error mounting EFI on disk /dev/disk0

So it seems the actual file copying worked and completed 100%, but something is wrong with EFI, and that in turn caused the progress bar to hang at 90% of complete.

How do I fix this? Alternately, is it basically done and can I just go ahead and ignore the EFI message, shut down Winclone and try to boot into Windows?


Also, in case it makes a difference, a number of Winclone processes are still alive in the machine :

jrc@mbp15 Winclone % ps ax |grep Winclone
586 ?? S 0:00.36 /Applications/ Menu
655 ?? S 1:19.70 /Applications/
726 ?? Ss 0:00.03 /Library/PrivilegedHelperTools/com.twocanoes.WincloneHelper
728 ?? Ss 0:33.63 /Applications/
988 s000 S+ 0:00.00 grep Winclone


EFI must be the 1st partition, not the last one
use Disk Utility for partitioning
/dev/disk3 (external, physical):
0: GUID_partition_scheme *240.1 GB disk3
1: EFI EFI 209.7 MB disk3s1
2: Microsoft Basic Data Windows 239.8 GB disk3s2

This is the current state of the partition list while the restore is still hanging (I haven’t killed it yet). The same machine worked correctly before in both Windows and Mac OS until Windows crashed, which is why I had to restore it using Winclone into the exact same place it used to be in before. It shows an EFI partition, presumably from the last time Windows was installed. Is it correct, and if so, can I just kill Winclone and try to reboot into Windows on the Bootcamp partition and expect it to work, or do I need to do anything else first?

jrc@mbp15 Winclone % diskutil list
/dev/disk0 (internal, physical):
0: GUID_partition_scheme *4.0 TB disk0
1: EFI EFI 314.6 MB disk0s1
2: Apple_APFS Container disk1 1.4 TB disk0s2
3: Microsoft Basic Data BOOTCAMP 2.6 TB disk0s3
4: Windows Recovery 557.8 MB disk0s4

/dev/disk1 (synthesized):
0: APFS Container Scheme - +1.4 TB disk1
Physical Store disk0s2
1: APFS Volume Macintosh HD - Data 245.8 GB disk1s1
2: APFS Volume Preboot 82.2 MB disk1s2
3: APFS Volume Recovery 528.9 MB disk1s3
4: APFS Volume VM 2.1 GB disk1s4
5: APFS Volume Macintosh HD 11.4 GB disk1s5

/dev/disk2 (external, physical):
0: FDisk_partition_scheme *1.0 TB disk2
1: Windows_NTFS Winclone15 1.0 TB disk2s1

Also, in case it matters, I am using OS 10.15.7 Catalina, and the MacBook Pro is a 2019 model. Looking at the Winclone menu, it has several choices under Tools :

  • Make WinPE bootable
    -Make EFI bootable
  • Make legacy bootable

Do I need to choose one of these as part of the restore, and if so, which one?
Or, do they apply only to the image creation stage and not to the restore?

Thanks for your help. I eventually shut Winclone down and rebooted into Windows and it worked without the need to do anything further. It seems the existing EFI from the previous installation did the job.

1 Like