Winclone corrupted my main MacOS drive: how to rebuild catalog?


well, my time with Winclone 7.34 has been brief. let me try to distill the scenario.

  1. Attempting to copy the BOOTCAMP partition from my MacBook Pro mid-2014 (10.13.6) to my 2011 Macbook Pro (10.13.6) in Target mode via a thunderbolt cable.

  2. The 2011 MBP has 2 drives. the main MacOS system drive (SAMSUNG 850) and a 2nd drive (CRUCIAL MX500) that is purposed for the BOOTCAMP destination clone.

  3. I tried to do a Volume to Volume cloning. After selecting the appropriate drives, the process began, but it gave an error and aborted shortly after beginning.

  4. I therefore tried to create an image. This worked.

  5. My next step was to restore the image. But I was unsure if was selecting the right destination drive because the previous Clone to Clone attempt had named the destination BOOTCAMP as well. so before i began, i decided to rename the destination so i wouldn’t be confused. I exited Winclone and powered down my 2011 MBP. i attempted to boot my 2011 MBP normally.

  6. it was at this time that i found out that my main MacOS drive on the 2011 MBP was now unreadable!

  7. i removed the drive (SAMSUNG) and placed it in an external case so i could access it with my 2014 MBP.

  8. using Disk Utility, it now sees 2 APFS partitions

    • AppleAPFSMedia
    • APFS Physical Store disk4s2 (ghosted)
  9. i tried to mount the ghosted partition, but nothing happens.

  10. i used the free version of Disk Drill to see if the information was still on the drive. it is, thankfully. but i really don’t feel like spending $90 to do a cumbersome recovery.

do you know of a recovery program to fix the file catalog or header?
are there issues with CRUCIAL drives in MBP?
what the hell happened?

thanks for reading this!

in good news, i was able to restore my image to the CRUCIAL drive after removing it and placing it in an external case. i then reinstalled it in the 2011 MBP. after a few reboots, Windows sorted things out and it is working as expected.

my MacOS SAMSUNG drive is still in shrouded purgatory, though.

I’m glad that you got it working again. I’m not sure why it wouldn’t not boot on the mac side. Winclone will rewrite the MBR but that should not effect macOS booting unless you had some very strange configuration. Winclone only restores data to the boot camp partition.

If you open the console and try and mount the ghosted partition, do you see any error messages?