Winclone EFI-Tool defunct in current version?

Hi there, I am using the current Version of Winclone 7.3.4. I am using a Mac that can use EFI to boot and does not require Legacy Boot. I have cloned directly to another disk and via an Image, but in both cases the result can not boot. I suspect the Efi-Tool that I also used on the SSD, has some inconsistency.

Due to further test, I come to the verified belief, that this is the case: When using (only displaying) Paragons NTFS for Mac 15, the (Winclone) result shows up as a Legacy Boot, but I had explicitly set this as an EFI-Boot with the Winclone-Tool-Menu.

So I come to believe that the current Version of Winclone is at fault in its way it writes the Boot-parameters. Can this be confirmed by Twocanoes or another member?

Regards, Peter

You can verify that it is set to legacy or EFI but looking at the MBR. Run this in Terminal:

sudo fdisk /dev/disk1

If you get output with a single line and ID EE, then it is EFI. If it has multiple entries, then it is set to legacy boot. See an example below of a EFI bootable Boot Camp partition:

mdscentral-6:15May2019 tperfitt$ sudo fdisk /dev/disk0
Disk: /dev/disk0	geometry: 15205/255/63 [244276265 sectors]
Sector size: 4096 bytes
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
 1: EE 1023 254  63 - 1023 254  63 [         1 -  244276264] <Unknown ID>
 2: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused
1 Like

Hello Tperfitt,

Thanks a lot for your answer. All the booting I did was internal in a MacBookPro and also on a MacBookAir. On Terminal fdisk: I tried the action but it seems that due to APFS I need to modify your suggested commend a bit. Is that correct? In your example, is disk1 the EFI or Bootcamp? I tried this on both, and have included both below, but can’t really interpret its meaning, if it is the correct try?
Thanks for your assistance, Peter