Winclone from MacBook air to latest MacBook Pro

Hi There,

I seem to be having some trouble going from a MacBook Air to a brand new MacBook Pro. When cloning from an Air to an Air it works fine, but same image wont load on the MacBook Pro. Is there some steps I need to do prior to restoring? I have tried converting to EFI as well. I keep getting INACCESSIBLE_BOOT_DEVICE

I am trying to clone Windows 10.

Any help greatly appreciated.

The INACCESSIBLE_BOOT_DEVICE is most likely caused by a missing driver (the apple SSD driver). Are you looking to deploy this or just move it as a one time operation? If it is one time, then I recommend starting up Windows in a VM and then installing the updating Boot Camp drivers. If you are deploying, I recommend including the driver in a sysprep’ed image.


Hi Tim,

This is a one time migration. You wouldn’t know where I may be able to find instructions on how to do the VM trick you mention? I have done a fair bit of googling, and unfortunately haven’t been able to find a resolution.

Appreciate your assistance.

This outlines the basic process. I am going to update it for Windows 10 soon.



I’ve just attempted a restore from a Win10 image from a 2017 MacBook Pro to a 2018 MacBook Pro with no success. 2018 restore was attempted by using BootCamp to create the partition, which configures the appropriate trust settings for Secure Boot, and then using Winclone to restore the partition into that space. I also disabled Secure Boot but with the same results (INACCESSIBLE_BOOT_DEVICE). I also saw the same when attempting to boot the 2017’s BootCamp partition via thunderbolt target disk mode on the 2018 system.

I can boot the OS without issue using VMware Fusion.

The Windows 7 driver install method assumes that the OS can boot, but I am struggling to install BootCamp while the OS is not booted natively (it obviously fails under VMware, as it doesn’t have direct access to the hardware), Installing the driver (right clicking the .inf file) doesn’t help - the driver needs to be installed and ready to go or else the system won’t boot at all.

I have yet to figure out how to install a driver for a device that’s not actually visible in Windows.

If you have sysprep’ed the image, you can inject a driver using this method:

I have done it successfully when migrating to a new 2018 T2TbMBP.


I ended up restoring to the bootcamp volume, booting via VMWare, sysprepping, re-imaging, using a Windows system to inject the drivers, restoring to bootcamp partition and then booting natively.

One word of warning - a Windows version upgrade should only be done from a native boot. I performed an update to 1803 within a VM and this broke the whole install. Glad I still had that image lying around!


Thanks for letting us know it worked (eventually) and the word of caution about the VM.


Getting back to this, still having issues. When I go to inject the drivers, I get an error: “Error 21 - Unable to access the image”

Do you happen to have any updated information?

Not sure. Did you get any further?


Yeah, managed to get it working. I used an app on windows called ‘ISO to USB’ to create the windows 10 bootable USB, and then copied the bootcamp drivers over to the USB, and then went through and injected the drivers to the bootcamp partitions which appeared to work. I don’t know how this process was different to creating a bootable Windows 10 USB, but for some reason this is what worked.