WinClone Image not booting

I have tried restoring my Winclone image but it will not boot.

I am running Winclone 8 (recently upgraded from Winclone 7 after MacOS upgrade to Catalina)

I had a bootable BootCamp partition working.
I wanted to roll back to an earlier image.
Selected the image to restore.
Winclode reported successful restore.

After Winclone restored the image it will not boot.

The Windows boot drive shows up when starting the iMac with [Option]
I have 2017 iMac (Model identifier 18.2) EFI is supported

I have tried creating the Recovery USB Flash Drive and followed the procedure on your webpage:

However that has not resolved the no-boot issue.
I have uploaded photo of the screen that I get when I try boot into Windows.

Can you please help resolve this.
Winclone is not much use if I cannot restore a working image!!

I can see the Bootcamp partition from the Mac when booted into MacOS.
All folders, files, etc have been restored by the Winclone Restore Image utility.
Just that it will not boot into the Bootcamp/windows.