Windows 10 Bootcamp: Install Issues to External SSD

Hi there,

So I am having issues cloning and booting Windows 10 to a solid state drive I have purchased for school. The MacBook Pro I have on hand is as follows:

18 AM

When I installed Windows 10 on the laptop itself it has no issue at all. When I tried to use migrate (drive-to-drive) feature to copy it onto my SSD it would fail towards the end of the migrate. I then learned that it would work if you firstly saved an image of the bootcamp and then restored the image to the SSD. I continued to go through with this and it seemed like it had worked. I removed the original boot camp off the internal hard drive of the laptop and tried to boot it from the SSD. However, when I went to go boot from the startup disk option it wasn’t there. It was also unrecognizable in Disk Utility.

I read up on some other threads and found that it could be that it wasn’t utilizing the feature that allows you to switch between Legacy and EFI Boot modes. When attempting to use Legacy mode the screen will black out give an error code saying “NO SYSTEM”. When using EFI mode the boot makes it a bit further by bringing up the windows logo before going to a blue screen where it gives you the famous “Inaccessible Boot Device” error. Is there a setting or option I’m missing that prevents this? I also attempted to select the Block-Based imaging (when I copied an image of the bootcamp) in preferences but it did seem like it solve any of the above issues.

Any advice or enlightenment on the situation would be greatly appreciated. Thank you.


A couple of things to try:

  1. Disable SIP prior to restoring. Since it is a 2013 Mac, SIP may be preventing writing the MBR.
  2. After restoring, do you see Windows files on the boot camp partition? Does Disk Utility show it as NTFS and is mountable?



Do I keep the block-based imagining on when saving an image of my bootcamp? And where and how is the SIP disabled?


Disregard my last post (unless I am not to be using block-based imaging).

I have managed to disable the SIP. Leaving the Block-Base imaging on and with SIP disabled I then reformatted my WD 250 GB SSD to a FAT32 format with GUID Partition Map. I then made an image of my Windows 10 bootcamp that saved with no issue at all. I then installed the image to my SSD and it also had no issue at all. I then deleted my Windows partition from the internal hard drive and continued to restart into Windows using the SSD. I then got this screen:

Which is similar to the issue I was having before. After I got this issue I returned to OSx and checked Disk Utility and yes, I can in fact is the bootcamp drive and it says that it is “External Physical Volume Windows NT File System”. Any other ideas?


I suspect these errors are happening due to a block size mismatch and using block-based imaging. To see if this is the case, run this in the terminal:

diskutil info disk0

and look for the entry for “Device Block Size”. Do this for both the source and the destination. You can get the disk numbers by running:

diskutil list

and should should see entries like “/dev/diskX” for each disk. replace the disk0 above in the diskutil info command to see the physical block size of each disk.


I just successfully migrated my internal Win 10 BC to an external SSD using WC 6. I think you have it mostly correct: use an intermediate image, format with GUID Partition Map, and use the EFI booting.

However, If your SSD is USB, you may be running into the problem that standard (non-To-Go/portable) Windows 10—what most of have in BootCamp—does not load the USB device driver before searching for the main windows partition during boot. The fix is described here:

But, it involves editing a registry key on your un-bootable partition. The easiest (but long) way to fix it would be to restore your internal BootCamp, make the registry fix, and then re-image back to the external SSD like you’ve just done.

However, I was able to use VMWare Fusion to boot Windows directly from the external drive using a “raw” virtual disk connection to the SSD. I generally followed the procedure listed here:

The newest Fusion has slightly different dialogs, but the options are the same. One other difference is that you may need to change the “ide1.1” lines to “ide1.0”—I had no other ide devices in the newly-created VM.

Once Windows boots in the virtual machine, you can use “regedit” to update the BootDriverFlags key to 14 (hex) as described in the video. This change tells the Windows boot process to load USB drivers during booting. Shut down the VM and restart your Mac into the EFI boot device.

For me, the first “real” boot off the SSD made some changes (driver tweaks?) and rebooted again before landing at the login window. I haven’t done too much after that yet, but most things appear to be OK at that point.

Parallels or VirtualBox may work for this fix as well, but I can’t point you at any step-by-steps for those.

As a last resort, in my searching I ran across a few hits that suggested you can edit the registry of another partition from a working Windows installation. If the raw disk method failed, I was planning to try and use a simple windows VM and attach the USB drive to try that out. I didn’t end up needing to do that, so I can’t say for sure that it would work…

Good luck!

  • mh