Windows 10 updates can't install on external Bootcamp SSD

I have a Bootcamp Windows 10 installed on an external SSD. No problem.
When I start Windows since sometimes however I get an alert saying : “Can’t install updates”.
The Windows updater also says : “Feature update to Window 10, version 1803 - error 0x80248007”
Is this a problem due to Winclone ?
I run Winclone 6.2.2 on HighSierra.

Seems related to the migration, but not really Winclone. Did you try some of these steps?


None of these steps worked.
In Method 1, I could delete the content of folder Download but I couldn’t delete the content of folder Logs as well as the files DataStore.edb and DataStore.jfm
System says : “The action can’t be completed because the file is open in Application Information”.
Stopping the Windows Update service didn’t help.
Method 2 and Method 3 didn’t work

Sorry, I made a mistake and I could finally delete these items.
But after restarting the computer and running the Windows Updater, system says :
Windows 10 couldn’t be installed. You can’t install Windows on a USB flash drive using Set=up.
Any idea ?

I have seen this as well and it is a Windows issue. I encountered this when trying to
do the upgrade to 1803. There was no Winclone or Bootcamp involved when I did the
1709 installation. It was also quite happy doing the usual updates. But, when the upgrade
to 1803 came out, I got that USB error message regardless of how I tried to do the upgrade.

This is what I think too.
I tried Method 1 and Method 2 indicated in tperfitt’s reply .
As of Method 3 … you have to buy a magic driver updater. Hmmmm. The string is a bit thick as we say in French and it might be that Method 1 and Method 2 never really worked … leading then the user to buy Method 3.
But this is a speculation of course.

Thanks for posting your results and sharing what you learned. I’ll do some testing on this side.


Hi Tim,

I just did another Windows 10 update trial and I got again the following message:

Feature update to Windows 10, version 1803 - Error 0x80248007

Did you make some progress in your testing ?

Not yet. On my list.


Feature update to Windows 10, version 1803 - Error 0x80248007

This is the message I keep getting ?
Did you make some progress in your testing yet ?

Run command prompt as administrator and run the command

net start msiserver

I was able to update my external drive this way. Let me know if this does not work.

No this didn’t help and I got the same error again

Could you update manually from the Microsoft website?

I will keep testing other alternative options.

I had a Bootcamp Windows 10 on an external SSD. I was trying to install it on my Acer laptop. But I was unable to do that because of the server issue. Then I go through It. From here I got the proper solution.