Windows 10 won't even attempt to boot

I’m trying to migrate a Windows 10 installation from a 2012 Macbook Pro to a 2018 Macbook Pro. On the old computer, I ran sysprep and created an image with Winclone 7.1.3. I created a new Bootcamp partition on the new computer and used Winclone to restore the image. When I restart the computer and hold down the Option key, the option to boot into Windows is there. When I select it, the screen goes black for about a second and then the Apple logo appears and it begins booting Mac OS. I’ve tried the “Make EFI bootable” option from the Winclone Tools menu but that didn’t help. What am I missing?

The new 2018 MacBook Pro has secure boot turned on by default, but doesn’t allow Windows secure booting until you install Windows the first time. Alternatively, you can also run this command in Terminal:

sudo nvram 94b73556-2197-4702-82a8-3e1337dafbfb:AppleSecureBootWindowsPolicy=%01

We are currently adding to Winclone.


Thanks. Do you have a reference for where that value came from?

Will it fix my problem? I use Winclone 6 and looks like have same issue with external drive booting.

External booting is different from Secure Boot. You can turn on external booting from the recovery partition on the new MacBook Pro 2018: