Windows 7 bootcamp does not boot after cloning

I have recently upgraded my older SSD to a larger one. I successfully cloned MAC partition (from old SSD), resized it with Disk Utility - everything runs well on Mac side. Then, I created a bootcamp partition with Disk Utility and cloned my old bootcamp partition (from old SSD) with Winclone (most recent one) - everything went well, but when restarting (with option key) I saw EFI boot and, after selecting it - black screen, will not boot. I used Winclone to set it to Legacy, restarted - now it shows Windows (with Option key) but will not boot; instead, when I select it to boot, it shows Apple logo and progress line is not moving. Mac boots well, no problem.

Any help will be appreciated.

Here some system details:

Mac Book Pro (retina), mid 2014, macOS Mojave 10.14.6, Windows 7 on bootcamp (everything worked well on the old SSD).

and from Winclone log:

2020-03-19T20:06:56-04:00:Starting Helper Tool
2020-03-19T20:06:56-04:00:setting up listener for mach service com.twocanoes.WincloneHelper
2020-03-19T20:06:56-04:00:Getting new connection request
2020-03-19T20:07:00-04:00:Volume mounted Read/Write at /Volumes/BOOTCAMP
2020-03-19T20:07:00-04:00:Updating MBR On Device
2020-03-19T20:07:00-04:00:updating MBR and partition info
2020-03-19T20:07:01-04:00:check to see if we are missing the BOOT folder and have one in the image to restore
2020-03-19T20:07:01-04:00:Boot Manager is at (null) and Boot File is at (null)
2020-03-19T20:07:01-04:00:Mounting /dev/disk0s3
2020-03-19T20:07:02-04:00:Mounted at /Volumes/BOOTCAMP
2020-03-19T20:07:02-04:00:Found BOOT folder or boot.ini at top level so we have a standard Windows bootable Windows partition
2020-03-19T20:07:03-04:00:Volume mounted Read/write at /Volumes/BOOTCAMP
2020-03-19T20:10:34-04:00:Winclone 8.1 (48104)
2020-03-19T20:10:34-04:00:Product ID:Winclone Standard
2020-03-19T20:10:35-04:00:Model Identifier: MacBookPro11,2
2020-03-19T20:10:35-04:00:=================diskutil list=================
2020-03-19T20:10:36-04:00:/dev/disk0 (internal):
0: GUID_partition_scheme 960.2 GB disk0
1: EFI EFI 209.7 MB disk0s1
2: Apple_APFS Container disk1 599.5 GB disk0s2
3: Microsoft Basic Data BOOTCAMP 360.3 GB disk0s3

/dev/disk1 (synthesized):
0: APFS Container Scheme - +599.5 GB disk1
Physical Store disk0s2
1: APFS Volume Macintosh HD 89.7 GB disk1s1
2: APFS Volume Preboot 42.1 MB disk1s2
3: APFS Volume Recovery 510.4 MB disk1s3
4: APFS Volume VM 1.1 GB disk1s4

I wonder if it is related to SIP. Have you tried disabling SIP and restoring?


I have disabled SIP for setting Legacy, but not while cloning. Are yo saying that I shall disable SIP and do cloning again? I used volume-to-volume cloning (old SSD attached via USB), not creating image and restoring it.

I have disabled SIP and cloned again, with the same result. However, I noticed a strange message in the Winclone log

2020-03-20T23:24:45-04:00:Ignoring SIP status and updating MBR
2020-03-20T23:24:45-04:00:Updating MBR, 96.000000% complete
2020-03-20T23:24:45-04:00:updating MBR and partition info
2020-03-20T23:24:45-04:00:SIP is enabled so skipping MBR Update

somehow, Winclone thinks SIP is enabled - I did check the status after cloning again:

System Integrity Protection status: disabled.

Is something wrong here?

I run “make legacy bootable” and it worked - no complain about SIP,

2020-03-21T11:09:38-04:00:Starting Helper Tool
2020-03-21T11:09:38-04:00:setting up listener for mach service com.twocanoes.WincloneHelper
2020-03-21T11:09:38-04:00:Getting new connection request
2020-03-21T11:09:41-04:00:Volume mounted Read/Write at /Volumes/BOOTCAMP
2020-03-21T11:09:42-04:00:Updating MBR On Device
2020-03-21T11:09:42-04:00:updating MBR and partition info
2020-03-21T11:09:43-04:00:check to see if we are missing the BOOT folder and have one in the image to restore
2020-03-21T11:09:43-04:00:Boot Manager is at (null) and Boot File is at (null)
2020-03-21T11:09:43-04:00:Mounting /dev/disk0s3
2020-03-21T11:09:44-04:00:Mounted at /Volumes/BOOTCAMP
2020-03-21T11:09:44-04:00:Found BOOT folder or boot.ini at top level so we have a standard Windows bootable Windows partition
2020-03-21T11:09:45-04:00:Volume mounted Read/write at /Volumes/BOOTCAMP

but no luck with booting Windows anyway.

About 5 years ago, I had a similar problem that had nothing to do with WinClone. The problem came from the fact that the Windows installation seems to expect that any new partition size be EXACTLY the same as the partition size in which the installation was initially made.

This conclusion came after I backed up the Win7 installation, resized the Win7 (BootCamp) partition on my iMac, and did a restore to the new partition. It never worked. It was easier to create a new installation from scratch.

Thanks a lot for the information! In my case I see Apple logo after selecting Windows to boot. This seems to suggest that Windows does not even have a chance to start booting. I’ll keep looking into it before giving up :slight_smile: Someone else has the same problem with OWC SSD, posted on this forum.

I actually bought a OWC SSD to test and had lots of issues getting it to boot. I need to find it and do some further testing.


In my case, macOs boots, but the disk logo it shows with option key is yellow, as for external drive, even though in Mac configuration it is correctly identified as internal. I’m wondering whether Windows does not boot because the drive is incorrectly identified as external at some point. OWC has identified this problem and posted OWC Dual Boot Enabler , which I installed but this did not help.