Error 87 when running dism command (INACCESSIBLE_BOOT_DEVICE)

I’ve created an image from bootcamp on a 2016 15" Macbook Pro and have restored the image on a new 2019 16" Macbook Pro. When trying to run windows I ran into the “INACCESSIBLE_BOOT_DEVICE” error.

I followed the instructions from the knowledge-base but was unable to inject the drivers in the last step.
https://twocanoes.com/knowledge-base/resolving-inaccessible_boot_device-error-after-restoring-winclone-image/

I found the “windows” and “users” folder on drive X and the flash drive was assigned to C. When i run the command
dism /Image:X:\ /Add-Driver /driver:c:\$WinPEDriver$ /recurse

I get

error: 87: The /Image option that is specified points to a running Windows installation. To service the running operating system, use the /Online option.

The bootcamp drive shows up when I’m running MacOS and I’m even able to use Parallels VM to run windows. I’ve also tried moving the applessd driver files to the windows/system32/drivers folder as described in this post


but no luck, I still get the “INACCESSIBLE_BOOT_DEVICE” error.

Anyone else have the same issue? I wasn’t able to find anything in the forum about the error 87 issue.

Solved it. Was an error on my part. I glanced over step 7 & 8 in the post below. Turns out I needed to boot from the virtual DVD drive in Parallels to run the dism command without error, I was still trying to do it from the flash drive.