INACCESSIBLE_BOOT_DEVICE (SOLVED!) Mac Pro 2018


#1

Hi All,
I just wanted to give everyone an update on my past few nights trying to resolve the INACCESSIBLE_BOOT_DEVICE issue. This has literally driven me insane but I finally resolved it.

The scenario is: 2016 mac book pro, with bootcamp native. Purchased new 2018 MBP, need to migrate it to that machine.

Steps:

  1. Take a clone using winclone standard (block by block worked for me, as both machines are 4mb block size).
  2. Create the new bootcamp partition on the new machine using disk utility, MS-DOS formatted.
  3. Using winclone on the new machine, restore the clone onto that partition.
  4. Here’s where it is going to make or break you, just follow me here if you want to do this the least painful way… Install Parallels desktop on the new machine. (Just use the trial or whhatever, you can ditch this later no problem.)
  5. Import the bootcamp partition as a virtual machine into parallels.
  6. Download the windows 10 ISO latest (https://www.microsoft.com/en-au/software-download/windows10)
  7. Attach this into the CD device in parallels, click into ‘boot order’ and enable ‘choose boot device on startup’ checkbox.
  8. Start the VM, hit ‘enter’ key to start from a boot device, choose the DVD device, this is your windows 10 attached disk.
  9. Choose a language in the windows installer screen
  10. Click repair in the bottom left corner.
  11. Click shift f10 to start the windows command prompt (youre going to need a keyboard for this sorry!! touchbar wont work here… massively painful, I know - I got lucky I had a usb-c USB-A adapter and an old keyboard so that I could do it).
  12. Follow the steps here from this point: https://twocanoes.com/knowledge-base/resolving-inaccessible_boot_device-error-after-restoring-winclone-image/
  13. When you boot into thhe windows partition by holding down the option key whhen restarting, you’re still going to get an error saying inaccessible_boot_device… bare with me now.
  14. Boot back into the mac on the new machine, and now start the vm in parallels, this time let it run thhrough the normal boot process, a blue screen will appear… but dont worry! Hit ‘Enter’ here to ‘retry’!! it will actually boot into windows… hoorah.
  15. Now at this point you just need to make sure that the native bootcamp can load theh correct appleSSD.sys drivers so that it can access your SSD to actually load theh operating system… thhis is where most people go wrong… dont go deleting that file, it will get you ‘past’ the issue, but it wont resolve it.
  16. In windows, navigate to c:\windows\system32\driverstore\filesystem (filesystem? i think its called that, its where all the driver files are). Search for applessd … youll probably find 2 here… take the LATEST one, go into that folder, copy all the files in there, then paste them directly into c:\windows\system32\drivers and overrwrite anything in there.
  17. Restart the machine in native boot by holding the option key and choosing your windows partition.
  18. Profit.

It should now find the right driver for your ssd and you should pass through. It will do a ‘getting devices ready’ at this point if you succeed, then just restart a few times and you’ll be sweet.

cosier at gmail if you have any extra questions.

Matt


#2

I’m not sure I can express how much I love you right now.
I could only love you more if I hadn’t spent a day and a half trying to figure this out before I found your post.
I am finally up and running with 32gb of ram and six sexy core i9 processor cores. Joy.
Productivity is on the rise :grinning:


#3

Worked for me also. And I can verify that it works with VMWare too. Had to re-install the Bootcamp drivers to get trackpad and keyboard to work. As stated in OP, a USB keyboard is required. A USB hub and mouse are handy too. 2018 15” MacBook Pro.