INACESSIBLE_BOOT_DEVICE, can't inject drivers

Hello, after restoring an image from a 2013 Macbook Pro to a new 2018 Macbook Pro, I’m getting the INACESSIBLE_BOOT_DEVICE error on starting the Windows partition.

I’ve tried the instructions here to resolve: https://twocanoes.com/knowledge-base/resolving-inaccessible_boot_device-error-after-restoring-winclone-image/.

I can boot the EFI volume, and start the cmd terminal, but it looks like I’m not able to access the migrated drive. Below is what I get in terms of each visible drive. C: is there including the WinPEDriver folder, but D: gives the error “The device is not ready.”
Any tips are greatly appreciated!

If you boot into macOS, does it show up in the Finder? If not, then there is either a block size issue or a restore issue. How did you migrate the data to the new mac?

tim

Thanks, Tim. The Windows partition does mount in Finder, and I’m able to see the files on it. I migrated my OSX image from a Time Machine backup, then used Winclone to restore an image from an external drive.

I’m stuck at the same spot, though my windows installation was showing under drive X. Have you checked that drive already?

I may not know what im talking about because when i run the command:
dism /Image:X:\ /Add-Driver /driver:c:\$WinPEDriver$ /recurse

I get error: 87:
The /Image option that is specified points to a running Windows installation. To service the running operating system, use the /Online option.

Yes, I ran into the same issue. If I remember correctly, the X drive is the EFI boot/thumb drive.

I was able to get past this error by following the steps listed in this post:

You will need to install a trial version of Parallels to do it, but it worked for me.

Thanks for the tip. I am able to boot from the iso in Parallels, but unfortunately it looks like the WinPEDriver folder isn’t there! Here’s what I can see when booted from the iso:

https://twocanoes.com/knowledge-base/migrating-windows-10-to-a-16-macbook-pro-2019-with-winclone-8/